[125] Continuous Preview

Bugs will be moved here once resolved.

Post » Sat Apr 13, 2013 11:58 pm

Link to .capx file (required!):
https://dl.dropboxusercontent.com/u/47035927/temp/test.capx

Steps to reproduce:
1. F5 to Preview
2. Go to C2, shift F5 to Continuous Preview
3. Catch the bug on the window.

Observed result:
A bug window.

Was very, very, very frustrating to get this bug isolated in a very tiny file, hope you understand how hard it was, I spent around 6 hours to isolate the problem with a code of 350 events, where sometimes worked fine and later didn't..

Maybe fishing could resolve =]

Expected result:
Continuous preview...

Browsers affected:
Chrome: yes
Firefox: yes/no
Internet Explorer: yes/no

Operating system & service pack:
Win 8 32bits
Construct 2 version:
R125TELLES08082013-04-14 00:54:03
ImageImageImageImageImageImage
B
93
S
19
G
12
Posts: 1,192
Reputation: 18,301

Post » Mon Apr 15, 2013 2:34 pm

It looks like you were hit by a bug that only existed in r124. In r125 it was fixed ("Cloning or copy/pasting various project elements could create things which did not work properly with save/load or the Persist behavior" - and I should have included, it also affected continuous preview, since that's based off save/load). So presumably you have cloned or copy/pasted some objects using r124 and the objects don't work with saving any more. Sorry, this is a risk of using beta releases. It shouldn't happen any more with r125+. (I can't reproduce rebuilding your example from scratch in r125, because it's already solved.)

It's possible to work around by editing the project XML directly:
- save as a project folder
- open the .caproj in a text editor
- find all <object-type ...> tags
- make sure all their "sid" values are unique. In this case both "Player" and "PlayerShadow" have a sid of 0 (I guess you cloned the player for the shadow?). If you change the "PlayerShadow" sid to 1, it should then work.

I'm going to have to close this since we already fixed the bug. Sorry for the trouble :-\Ashley2013-04-15 14:35:58
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Mon Apr 15, 2013 4:36 pm

This explain a lot of weird effects and unexplained effects on the game, lol.
ImageImageImageImageImageImage
B
93
S
19
G
12
Posts: 1,192
Reputation: 18,301

Post » Tue Apr 16, 2013 3:26 am

@Ashley

I started a brand new file and ported every sprite one by one, doing the entire code from scratch, and cleaning up a bit the project.

But now I'm getting an issue while using Continuous Preview.



And after it, a black screen. I'm so unluck dude, because Continuous Preview is so Awesome =\

This is a clean file with only a text object inside it, the text is not setup on the canvas, it's simple there, on the Projects Column.

https://dl.dropboxusercontent.com/u/47035927/temp/teste.capx

I isolated the file after trying everything again, one by one.

After deleting the text object and setuping creating another one, everything is working well.TELLES08082013-04-16 03:38:20
ImageImageImageImageImageImage
B
93
S
19
G
12
Posts: 1,192
Reputation: 18,301

Post » Tue Apr 16, 2013 6:50 pm

@TELLES0808 - that project has the same problem, both Keyboard and Debug_Txt have the same 'sid' value (72). Same workround should apply. I found and fixed one more problem for the next build where it could go wrong again if you copy and paste between projects, is that what you were doing?
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Tue Apr 16, 2013 10:42 pm

yes, porting the graphics. Should I redo everything from scratch?

By now, it's working without any problem when on Continuous preview, and is running very fast, 2 times better than before, same code, same things.

The last weird thing happening with this project (I did the whole code again trying to fix it, without success) is when exported to Arcade, the game doesn't start, after all this job, so it may be related?

http://www.scirra.com/FORUM/topic66445.html
ImageImageImageImageImageImage
B
93
S
19
G
12
Posts: 1,192
Reputation: 18,301


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests