[154] Tilemap bar won't load tiles

Bugs will be moved here once resolved.

Post » Tue Dec 17, 2013 5:48 am

Link to .capx file (required!):
https://www.sugarsync.com/pf/D6025908_4317202_6011572

Steps to reproduce:
Unsure of exact steps...
1. Create and edit a tilemap as desired.
2. Place tilemap on layout.
3. Later, select tilemap object on layout or in object bar.

Observed result:
The tilemap bar doesn't load any of the tiles even as the image editor for the tilemap object shows there is artwork there.

Expected result:
Selecting the object or layout instance will load the available tiles for that object.

Additional information:
I edited the Tile width and height parameters and clicked on the object in the object bar again. That seemed to fix part of it. But I don't see how that prevents the tiles from loading at all. The size of the tiles in the image editor is 24x24, whereas the default size of the tilemap object is 32x32. But that doesn't explain why other tilemap objects don't load even after having their parameters resized.

Browsers affected:
Chrome: N/A
Firefox: N/A
Internet Explorer: N/A

Operating system & service pack:
Windows 7 w/ Service Pack 1

Construct 2 version:
C2 r154 64-bitRhindon2013-12-17 06:05:58
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
141
S
24
G
8
Posts: 790
Reputation: 15,119

Post » Tue Dec 17, 2013 8:52 am

Just opened your .capx, clicked the tilemap object in the Layout window and went to Tilemap window and could select and edit tilemap as required.

I can't see a problem.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
136
S
31
G
86
Posts: 5,481
Reputation: 59,748

Post » Tue Dec 17, 2013 3:06 pm

Closing, we can't investigate this without specific reproduction steps.
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,351


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests