[209] Sprite Font turn invisible in editor mode

Report Construct 2 bugs here.

Post » Fri Jul 03, 2015 9:54 pm

Message: MatheusCastellar can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
Problem Description
Sprite Font disappear when trying to select it, or zoom.

Attach a Capx
Capx example: https://www dot dropbox dot com/s/ut67r8gum6ck3hm/bug_sprite_font.capx?raw=1

Steps to Reproduce Bug
  • ZOOM
  • Select


Before
Image

After
Image

-----------
Operating System
- Windows 8.1 64 Bits
- Core i3
- 1TB HD
- 8 GB RAM
- Geforce 210 (1 GB)

Construct 2 Version ID
209 beta.
B
68
S
17
G
2
Posts: 94
Reputation: 4,742

Post » Fri Jul 03, 2015 11:38 pm

Yes - finally!! This is the beginning of the editor problem with the set color shader! Finally, a working example of the problem.... (I am only pleased because I believe this will now be fixed - no more warped or vanishing sprites and sprite fonts....).
I only occasionally visit - I'm learning C# for Unity, but c2 is still a respectable game engine imo....
B
73
S
19
G
66
Posts: 2,198
Reputation: 42,188

Post » Sat Jul 04, 2015 12:06 pm

my sprites are 'invisible' on preview
layer where is the sprites i set scale to 3
But its not onli 'invisible' because i click everywhere (this is tic tac toe game) so i should end or win game quickly.... nothing happen
Image
B
109
S
25
G
43
Posts: 1,883
Reputation: 33,553

Post » Sat Jul 04, 2015 3:09 pm

The bug is hindering me. How to Fix It?
B
68
S
17
G
2
Posts: 94
Reputation: 4,742

Post » Sat Jul 04, 2015 3:18 pm

The only way to work around this bug is to turn preview effects to off.

Here's an easy link to the capx: https://www.dropbox.com/s/ut67r8gum6ck3 ... capx?raw=1
I only occasionally visit - I'm learning C# for Unity, but c2 is still a respectable game engine imo....
B
73
S
19
G
66
Posts: 2,198
Reputation: 42,188

Post » Wed Jul 15, 2015 11:14 am

I can't reproduce the problem. In the provided .capx, I can zoom in and out and select objects and everything appears correctly. I think this is probably a graphics driver bug, are your graphics drivers up to date?
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Wed Jul 15, 2015 12:09 pm

I have this on 2 laptops both using integrated graphics - the drivers for which are up to date... I've been seeing it for the last 2 years in bigger projects that use this shader.
I only occasionally visit - I'm learning C# for Unity, but c2 is still a respectable game engine imo....
B
73
S
19
G
66
Posts: 2,198
Reputation: 42,188


Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests