30 fps drop by just "walking"

Get help using Construct 2

Post » Fri Mar 27, 2015 12:37 pm

I'm sorry but I'm really confused right now. My game has basically nothing right now. Just the first scenario, which is 3 tilpemaps, 1 base and two for decorations.
When I start moving any sprite, drops 30fps in my phone. I'm intrigued. The project have 10 events and there are nothing that could do that. I've tried all movements behaviors, even move forward action.

Image
The object is travelling from the left of the screen to the end just to test.
B
45
S
19
G
3
Posts: 576
Reputation: 6,058

Post » Fri Mar 27, 2015 1:13 pm

could you post a capx ? or an overview (screenshot) of the involved events
Who dares wins
B
50
S
10
G
10
Posts: 1,728
Reputation: 12,866

Post » Fri Mar 27, 2015 1:26 pm

lennaert wrote:could you post a capx ? or an overview (screenshot) of the involved events


https://www.dropbox.com/s/38t313ei6witk ... .capx?dl=0

That's weird. The attachment tab of the forum disappeared for me here.
B
45
S
19
G
3
Posts: 576
Reputation: 6,058

Post » Fri Mar 27, 2015 1:59 pm

Your base tilemap seems to consume most.
As soon as you reduce the window size the frame speed picks up. And removing the base tilemap gives quite some fps back.

After the base its those 2 image decorations. Removing them also gives some fps back.

Perhaps its due to using 3 layers of tilemaps ? I have not used tilemaps that much, so I am not sure on that. Perhaps the tiles you used are a bit big ? or the overal size of the tilemaps are too big ?

Instead of using the 2 decoration tilemaps to place your other objects, perhaps use sprites ?

Also, you can set sampling to linear, looks better imo.
Who dares wins
B
50
S
10
G
10
Posts: 1,728
Reputation: 12,866

Post » Fri Mar 27, 2015 2:24 pm

lennaert wrote:Your base tilemap seems to consume most.
As soon as you reduce the window size the frame speed picks up. And removing the base tilemap gives quite some fps back.

After the base its those 2 image decorations. Removing them also gives some fps back.

Perhaps its due to using 3 layers of tilemaps ? I have not used tilemaps that much, so I am not sure on that. Perhaps the tiles you used are a bit big ? or the overal size of the tilemaps are too big ?

Instead of using the 2 decoration tilemaps to place your other objects, perhaps use sprites ?

Also, you can set sampling to linear, looks better imo.



How come. It's all about a bunch of repeated smaller tiles. If I don't use any movement, fps stays at 60. Removing all the decorations give me back about 10~15 fps. Is it right? It seems TOO limited for me. Tilemap should give me a lot advantage, not the opposite. Also, bear in mind that it's only one object moving, imagine a bunch of them.

The tiles are 32x32. Can't be that.
The tilemap object size doesn't affect performance by it self.
For the decorations: Using sprites wouldn't help because I would increase a lot my object count. Performance issue would be worse in this case.

I'm really getting frustrated with C2 regarding to performance issues in mobiles. I'm about to give up and perhaps trying to make games for PC only. Too limited in comparison with other engines, in my opinion. That's the conclusion I get after months doing my games and, after this project, I'm sure.
B
45
S
19
G
3
Posts: 576
Reputation: 6,058

Post » Sat May 07, 2016 9:49 pm

Performance issues here to with tile mapping and fps, but can't find answers
B
6
S
2
Posts: 16
Reputation: 482


Return to How do I....?

Who is online

Users browsing this forum: Curler, MPPlantOfficial, patmaru and 18 guests