8direction, custom movement, and solid interaction: bug?

Discussion and feedback on Construct 2

Post » Wed Jan 14, 2015 4:00 am

Is order of behaviors in an objects behavior list supposed to make any difference? If not, then this may be a bug.
Run the attached capx. The four walls have the solid behavior. They are pinned to a little blue square. The two colored arrows have 8 diretion and custom movement, and the blue square has custom movement. Press space bar to accelerate the walls with the red and green arrows inside it to about 500p/s or more, there is a readout above to show speed. Use the default 8 direction arrow keys to move the red and green arrows around inside the moving box. Notice how when encountering the forward wall, the red arrow behaves as you would expect, but the green seems to encounter the wall early and jitters there. At the back end of the moving box, the red behaves normally, and the green doesn't stop until it's passed partway through the rear wall. It gets worse as speed is increased.
The only difference between the red and green arrows is that the red has 8 direction behavior listed before custom movement, and green is the opposite order.
Is this somehow expected behavior, or should I submit it as a bug?
You do not have the required permissions to view the files attached to this post.
B
11
S
4
G
1
Posts: 159
Reputation: 1,803

Post » Mon Jan 19, 2015 7:11 pm

Bump. Anybody know anything about this phenomenon?
B
11
S
4
G
1
Posts: 159
Reputation: 1,803


Return to Construct 2 General

Who is online

Users browsing this forum: RoboticPhoenix and 3 guests