8direction movement blurred error How do I solve it?

Get help using Construct 2

Post » Mon Jul 28, 2014 3:39 pm

Good afternoon. I'm making a platformer game.
However, one problem occurred.

  [
'8 Direction 'move Behaviors to move forward when you use the object must with blurry jagged. Why is that? I do not know.

  I would like to move naturally.
]

  Passing friendly people you ever saw this article if you please, please help me.
B
3
Posts: 2
Reputation: 175

Post » Mon Jul 28, 2014 6:50 pm

Can you better describe your problem? I don't get this blurry and jagged thing... Perhaps share a screenshot or a capx file..?

(And why you are using the 8direction behavior and not the Platform behavior?)
composer - multimedia artist
www.eli0s.com/en/
B
69
S
27
G
6
Posts: 1,146
Reputation: 10,379

Post » Tue Jul 29, 2014 9:07 am

eli0s wrote:Can you better describe your problem? I don't get this blurry and jagged thing... Perhaps share a screenshot or a capx file..?

(And why you are using the 8direction behavior and not the Platform behavior?)


Sorry, my explanation was insufficient.
I want to create a game in the top view and side view of the switch of the game.

Both 8direction behavior and Platform behavior I used.
And when you move the image blurring phenomenon that also occurs in the Platform behavior.

Occur in a particular period and not all sections of this issue should be what I am not sure about the former.
  Oh, great savings, please help me how to solve it.


Attach the video link.
Please see YouTube 720p resolution settings.

this problem : http://www.youtube.com/watch?v=PANveH0Q8QA

I want a clean look of movement: http://www.youtube.com/watch?v=b-BoOEdT1LY
B
3
Posts: 2
Reputation: 175

Post » Tue Jul 29, 2014 11:11 am

I am not sure I can clearly see the difference in performance between the two videos that you posted. Perhaps the first one has more abrupt flow, a staggered frame rate, this is what you describe as jagged. I don't see any blur though. I am confident that between the video capture software and the youtube decoding, some information is lost and that you see more of this problem than I do.

Now, first of all I should say that Construct 2 does have an issue with occasional staggering. It is described on other posts, basically, it looks like every few seconds a frame or two are being dropped and as a result the movement losses its continuity. It's a subtle, but evident effect that I wish it wasn't there.

In your case, I wonder if you use the Platform Behavior in conjunction with the 8directional Behavior...? If yes, when you walk and jump around in the platforming section of your game, do you have the 8directional Behavior deactivated? If not, perhaps there is some conflict between the 2 behaviors and that is causing the jagginess...

I can't think of something else for now, if you like you can attach your capx file for the rest of us to see and check if there is some error from your part and/or if we experience the same problem as you do.
composer - multimedia artist
www.eli0s.com/en/
B
69
S
27
G
6
Posts: 1,146
Reputation: 10,379


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 48 guests