9 patch and tiled object move if placed outside of layout

Bugs will be moved here once resolved.

Post » Wed Sep 03, 2014 12:15 am

Problem Description
If you ever place either a tiled object or 9 patch outside of the layout on either the left side or the top, when you start the game it will move it right or down a single pixel respectively.

Attach a Capx
https://dl.dropboxusercontent.com/u/7282045/borderoffset_tiled.capx

Description of Capx
There are 3 layouts that illustrate the problem - the 9patch and tiled layouts show that when you run the game the assets get moved down and left a single pixel whereas the Sprite has the expected behaviour whereby it doesn't move at all.

Steps to Reproduce Bug
  • Create a tile or 9 patch asset
  • Place it slightly outside to the left or above the layout
  • Run the layout

Observed Result
Observe that asset has moved a single pixel in opposite direction to the one that it was moved outside of

Expected Result
That neither the 9 patch or tiled object do not move from where they are placed in the editor

Affected Browsers
  • Chrome: (YES)
  • FireFox: Untested
  • Internet Explorer: (YES)
  • iPhone export (CocoonJS): (YES)

Operating System and Service Pack
Windows 7 SP 1

Construct 2 Version ID
Release 178
B
44
S
9
G
2
Posts: 141
Reputation: 4,172

Post » Thu Sep 04, 2014 3:38 pm

Thanks, should be fixed in the next build. Looked like 'Pixel rounding' rounded the wrong way sometimes.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,238


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest