A cap with a few bugs

Post your own tutorials, guides and demos.

Post » Sat May 30, 2009 5:12 am

This file was created in 99.2. The black box sprite has bone movement behavior that connects the other 2 sprites. There is a looping animation on the bones. All the sprites are in a container. The black box is set to destroy on the start of the layout. When you left click the mouse, the black box is spawned at the mouse position.

Bugs:
1) The black box is not destroyed when the layout starts. The sprites in the container should be destroyed too.
2) No animation plays
3) Left clicking the mouse only creates the black box and not the other sprites in the container.
4) The ScaleObjects event sheet is not used, but there is a crash when i try to delete it.
5) Turning off "destroy object on start of layout" (on the black box) has no effect

Going to submit this to the tracker, but wanted to get some eyes on it first in case i'm missing something or doing something wrong.
B
77
S
49
G
25
Posts: 346
Reputation: 17,409

Post » Sat May 30, 2009 5:43 am

1 - All objects in the container must be set to destroy at the start. Each object in a container essentially acts as a "seed" for the rest of the objects.

2 - I checked the bone behavior and didn't see any animation in there. Only one keyframe, so nothing will move.

3 - The other objects are being created, they're just being created at the location of the original object.

4 - Report it, man. ;)

5 - See number one.

Also, just thought I'd mention that there's currently a bug with the bone behavior where if you have more than one of an object with the bone behavior, only the latest iteration will have bones assigned to it. Hope all this helps. :)
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Sat May 30, 2009 9:37 am

Number #4 is fixed, so don't bother reporting it if you haven't.
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Sat May 30, 2009 2:19 pm

Thanks guys. Not sure how i missed the animation thing, guess it crashed and the animation didnt save.
For #1 I thought that in earlier versions if you destroyed an object in a container it would destroy all of them, even at start. Ill have to check that again.
B
77
S
49
G
25
Posts: 346
Reputation: 17,409


Return to Your tutorials & example files

Who is online

Users browsing this forum: No registered users and 0 guests