A workaround to crashes with Parallels Desktop

Discussion and feedback on Construct 2

Post » Sun Jan 17, 2016 9:10 am

I didn’t want to put this in the Bugs section because, not only is it really not a confirmed bug with Construct 2, my point in posting this is to give a workaround to a problem I had and one I saw other users have had as well: Construct 2 crashing for Mac users when using Parallels Desktop (I use a MacBook Pro with Parallels version 11). I went through a few hours of pain to find this out and I want other people to benefit if possible.

I found out that when you use Parallels Desktop in non-full screen mode, and then minimize Parallels Desktop while you have an event sheet open, it messes with the graphics drivers- you’ll see the event sheet go completely blank- and eventually, Construct 2 will crash. Because it crashes on the event sheet, any subsequent attempts to open the project will attempt to open it right where it left off: on the event sheet. This might be why people have been reporting Construct 2 crashes upon opening an existing project. For the people who have Construct 2 crash while opening a new project, I can’t give any feedback on that, but if you’re trying to open an existing project and Construct 2 crashes, try doing these steps.

To fix a project you can't open:

Shut down the virtual machine, then in the Parallels Desktop preferences (the gear icon), go to Graphics and click on Advanced Settings. Disable 3D acceleration (thanks to Ashley for helping me discover this with a post from long ago). Now start the virtual machine and Construct 2, and you can now open the project that has been causing Construct 2 to crash. (Technically it’s an issue between the virtual machine graphics driver and Construct 2, not the project itself, although it won’t happen to every project, only to the one that was open when you minimized Parallels Desktop. If Construct 2 crashes on you with every project you attempt to open, I can’t help with that unfortunately.) You don't want to keep 3D acceleration off for good though because the performance is much better with it. So, close the event sheet tab in the project that has been crashing, make a change to the project, and save it as a new project with a name different from the one that Construct 2 crashed with. Shut down the virtual machine again, then re-enable 3D acceleration. Start the virtual machine and Construct 2 and attempt to open the new project. Verify that you can now open the event sheet that previously caused Construct 2 to crash. If not, repeat these steps again; it might take more than one try (but don't try for too long because your issue might be different from the one I had). Once you’ve verified that the event sheet can be opened with 3D acceleration enabled, you can delete the project that caused Construct 2 to crash, then save the new project with the previous project’s name.

To prevent this from happening again in the future:

Shut down the virtual machine, then in the Parallels Desktop preferences, go to Options (at the top), click on Startup and Shutdown, and in the Startup View dropdown, select full screen. This will run Parallels Desktop in full screen mode whenever you start it. Running Parallels Desktop in full screen only will make sure you don’t minimize the Parallels Desktop window when it has an event sheet open. Whenever you want to leave the Parallels Desktop view, you can put your mouse at the bottom of the screen so that the Mac dock comes up, and click on the Parallels Desktop icon to get back to your Mac.

I hope this helps even one person who has had Construct 2 crash on them while using Parallels Desktop. I was scared I had wasted a good amount of money on Parallels Desktop and Windows 10 (which I bought solely for Construct 2), and I don't want anyone to suffer through such anxiety.
B
4
S
1
G
1
Posts: 1
Reputation: 802

Return to Construct 2 General

Who is online

Users browsing this forum: Tinimations and 4 guests