About Anchor/Viewport laggggggggggg

Discussion and feedback on Construct 2

Post » Fri May 09, 2014 6:36 am

http://hkfcp.com/ttt
here is my game(Casually enter ID&PW)
i feel some lag on Anchor/Viewport when player moving
just me?
You do not have the required permissions to view the files attached to this post.
B
17
S
7
Posts: 360
Reputation: 2,202

Post » Fri May 09, 2014 9:44 am

I couldn't load the game but I suggest you to try to search about doing a layer with a parralax of (0, 0), this should eradicate lag (I think the manual precise that anchor behavior is meant to be used on layer with (0,0) parralax)

Edit: I see it now, DOM Elements (button and textbox) are not actually drawn by C2 inside the canvas, they are on top, and so I do not think moving them in a non laggy way is doable, could be wrong though.
Game design is all about decomposing the core of your game so it becomes simple instructions.
B
53
S
22
G
18
Posts: 2,122
Reputation: 17,123

Post » Sat May 10, 2014 4:39 am

Aphrodite wrote:I couldn't load the game but I suggest you to try to search about doing a layer with a parralax of (0, 0), this should eradicate lag (I think the manual precise that anchor behavior is meant to be used on layer with (0,0) parralax)

Edit: I see it now, DOM Elements (button and textbox) are not actually drawn by C2 inside the canvas, they are on top, and so I do not think moving them in a non laggy way is doable, could be wrong though.

textbox is very good not lagggggggg
but the UI(image/button)=lagggggggggg
B
17
S
7
Posts: 360
Reputation: 2,202

Post » Thu Oct 23, 2014 1:56 pm

Same problem/ Did you find answer?
- I try to update with X with ViewportLeft every 0.01 second (have same problem)
- Anchor (have same problem)
B
6
S
2
Posts: 10
Reputation: 622


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests