about physical

Get help using Construct 2

Post » Tue Oct 04, 2016 11:06 am

Hello, I have several objects with physical top of each other, I have friction 1 (for non-slip), the collision polygons are fine but when they are all 20 seconds begin to separate gradually until they fall ...
Last edited by statham on Wed Oct 05, 2016 12:24 pm, edited 1 time in total.
B
13
S
2
Posts: 297
Reputation: 1,717

Post » Tue Oct 04, 2016 11:59 am

They didn't fall, but I can see in debug-mode that the x and y-positions are changing slightly. It stops, if I turn off the animations. I assume that the objects change slightly the size in the animations.

I don't have the problem with chipmunk-physic. So I think it's a problem with the physic-behavior.
B
24
S
3
G
1
Posts: 451
Reputation: 2,165

Post » Wed Oct 05, 2016 9:28 am

I'm sorry I can not understand the English.
You say that some frame has a different size and why is that?
Or I have to set something physical?

Thanks :D
B
13
S
2
Posts: 297
Reputation: 1,717

Post » Wed Oct 05, 2016 10:18 am

What I mean is when the animation of your objects are playing you can see in debug-mode that the x and y-position of the objects are changing. This is only when the animation is playing.
If you use chipmunk-physics from R0j0hound this problem doesn't exist. So I assume that is a problem with the physic-behavior.
B
24
S
3
G
1
Posts: 451
Reputation: 2,165

Post » Wed Oct 05, 2016 10:49 am

Thanks :D
B
13
S
2
Posts: 297
Reputation: 1,717


Return to How do I....?

Who is online

Users browsing this forum: DarknessGamingDK, Eren, webebiz and 3 guests