AI Issues

Get help using Construct 2

Post » Fri Jan 25, 2013 4:57 pm

Hi there,

I'm new to Construct 2 and I have some AI issues.
Some enemies work fine but others don't work as good although it's basically the same enemy copied with ctrl. Don't know why but they don't mirror properly. I use the bullet behavior

This is my first attempt of a platformer game and it's only for personal use, i took the sprites from the internet.

Here it is, play it and you'll see some zombies walking backwords.
https://www.dropbox.com/s/qrdl3s4iewdwvte/Test.capx

Any ideas?
B
3
Posts: 3
Reputation: 281

Post » Fri Jan 25, 2013 6:33 pm

It looks like that particular zombie is set to walk right first. But on spawn it is placed facing left. I can't tell from your logic, but it looks like the zombie is being moved to the right but the platform simulate movement is not being used possibly... can't really tell what the issue is yet, I will keep looking though.
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,428

Post » Tue Jan 29, 2013 9:47 am

Any other ideas? I don't know why that zombie is different :)
B
3
Posts: 3
Reputation: 281

Post » Tue Jan 29, 2013 10:02 am

Problem seems to be caused by the fact that all your zombies are initially walking to the right(speed 30 is towards right) and facing left. You could either rotate them all to face right initially, or change their initial angle of motion to left.

Nothing wrong with moonwalking zombies though! :)
B
24
S
8
G
7
Posts: 756
Reputation: 7,202

Post » Wed Jan 30, 2013 2:43 pm

[QUOTE=vee41] Problem seems to be caused by the fact that all your zombies are initially walking to the right(speed 30 is towards right) and facing left. You could either rotate them all to face right initially, or change their initial angle of motion to left.

Nothing wrong with moonwalking zombies though! :)[/QUOTE]

Thanks alot! I managed to solve all those moonwalking zombies :)

How do you find my game? :)
B
3
Posts: 3
Reputation: 281

Post » Wed Jan 30, 2013 3:09 pm

[QUOTE=N0NAM3] [QUOTE=vee41] Problem seems to be caused by the fact that all your zombies are initially walking to the right(speed 30 is towards right) and facing left. You could either rotate them all to face right initially, or change their initial angle of motion to left.

Nothing wrong with moonwalking zombies though! :)[/QUOTE]

Thanks alot! I managed to solve all those moonwalking zombies :)

How do you find my game? :)[/QUOTE]


Really nice graphicstyle, great castlevania vibe! Looking forward to playing finished version :-)
B
24
S
8
G
7
Posts: 756
Reputation: 7,202


Return to How do I....?

Who is online

Users browsing this forum: Justin1967, qaisarehman and 32 guests