Airscape: The Fall of Gravity - OUT NOW!

Show us your completed creations made in Construct 2

Post » Mon Aug 25, 2014 8:55 pm

@sqiddster

Congratulations on winning the Best Use of Physics title.

Will check out the demo, the original game was great.
Vote for all the Construct 2 games on Steam Greenlight - Find them here
B
32
S
9
G
7
Posts: 444
Reputation: 6,731

Post » Mon Aug 25, 2014 9:14 pm

Congratulations!
B
15
S
3
G
3
Posts: 93
Reputation: 1,466

Post » Mon Aug 25, 2014 9:39 pm

Great demo.

One problem I encountered Level complete screen freezes, don't know if it is linked to the node-webkit freez problem or something else.
B
15
S
3
G
3
Posts: 93
Reputation: 1,466

Post » Mon Aug 25, 2014 11:30 pm

@Giganten Interesting. Does it freeze all the time, or just at some points?
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Tue Aug 26, 2014 3:09 pm

Freezing starts after all animals disappear in the whirlwind, at random intervals.
Asked a friend to test it too, played 1 or maybe 2 levels but he couldn't see any freezing.
B
15
S
3
G
3
Posts: 93
Reputation: 1,466

Post » Tue Aug 26, 2014 5:01 pm

Interesting demo.

- game lags and chugs in full screen mode. I'm talking sub 30 fps. (resolution must be downgraded even on strong pc to run at steady rate)
- changing the settings from standard to fast to faster has little to no effect on the performance. From what I can tell.
Last edited by TunaUppercut on Tue Aug 26, 2014 5:51 pm, edited 1 time in total.
B
10
S
3
G
1
Posts: 103
Reputation: 1,390

Post » Tue Aug 26, 2014 5:19 pm

@TunaUppercut this shouldn't be the case. What sort of PC are you on? Laptop? Does it have a dedicated GPU?
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Tue Aug 26, 2014 5:36 pm

Laptop with a dedicated GPU. I went to the NVIDIA control Panel and changed the settings to have every program use the dedicated video card.

I've also tried playing the game using a integrated card instead of dedicated but the game ran worse.

-CPU: Intel Core I7 4800MQ 2.7 GHz (Max Turbo 3.7GHz)
-GPU: GeForce GTX880M
- 16 GB Ram DDR3L 1600MHz
- Windows 8.1 64 bit

On windowed mode the game runs fine.
B
10
S
3
G
1
Posts: 103
Reputation: 1,390

Post » Tue Aug 26, 2014 7:00 pm

@TunaUppercut thanks for letting me know. It might be a Node-Webkit problem, I might try to get a Chrome build up for testing purposes.

On windowed it works fine, eh? Like, even if you stretch it to the size of the screen?
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Tue Aug 26, 2014 7:15 pm

If I use my integrated gpu (Intel HD Graphics 4600)
There are large fps dips in both full screen and window mode (unless I downgrade my resolution).

If I use my dedicated gpu (GeForce GTX880M)
There are only large fps dips in Full screen mode (lowering the resolution stops the dips).
Window mode runs at 60 fps at all times on any resolution.

stretching the window size did not change the frame rate.
B
10
S
3
G
1
Posts: 103
Reputation: 1,390

PreviousNext

Return to Completed Creations

Who is online

Users browsing this forum: No registered users and 1 guest