Aliased text

For questions about using Classic.

Post » Mon May 10, 2010 11:59 pm

Hello there

I was wondering if there was an easy way to get text to be displayed with absolutely no anti-aliasing whatsoever. I want them jaggies man! I needs them! :shock:

Obviously I've tried selecting "Aliased" in the Text Rendering option but that just makes them slightly less anti-aliased and I want them perfectly sharp to fit with my MSPainty graphical style. I'm aware of PixelRebirth's bitmap font solution (which I'll probably end up using if there's no other way) but I was kinda hoping there would be a simpler solution using the default windows fonts.

Any help is appreciated.
B
1
G
2
Posts: 4
Reputation: 633

Post » Tue May 11, 2010 12:19 am

They look completely aliased on my machine. Are you sure that the text is not between pixels? Try setting the position of the text object to round(.x), round(.y) and scroll to round(scrollx), round(scrolly). Also try a new.cap from scratch, insert a text object and preview.
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Tue May 11, 2010 11:49 pm

After digging around for a bit I found a thread saying that the Text Properties might be bugged in the latest unstable release (which is the one I'm using) so I take it that that is the problem. I found a workaround however. If I apply the Alpha Test Sharp effect to my text it will be rendered without any anti-aliasing, just like I want it.
B
1
G
2
Posts: 4
Reputation: 633


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 0 guests