All games on IE now black

Bugs will be moved here once resolved.

Post » Sun Feb 08, 2015 1:42 pm

Problem Description
As of 2/7/15 ALL of the games that I have made using Construct 2 generate a black screen in Internet Explorer.

Attach a Capx
____ They are at googledrive.com/host/0BzGYmojxn3PwczRvc3p3QjhKakU/games.htm

Description of Capx
____ ALL games, capx is not relevant.

Steps to Reproduce Bug
  • tried any of 15 games (as posted above)
  • tried on 3 different computers using Windows 7 and 8.1
  • Step 3 etc.

Observed Result
____ Entirely black screen with no response

Expected Result
____ expected the game to play

Affected Browsers
  • Chrome: no
  • FireFox: unk
  • Internet Explorer: YES

Operating System and Service Pack
____ Windows 7 or 8.1

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using 195
B
5
S
2
Posts: 12
Reputation: 499

Post » Sun Feb 08, 2015 5:28 pm

Update:

The same black screen appears on Firefox as well.

The games affected were developed using the 3 latest versions of Construct 2. They are at googledrive.com/host/0BzGYmojxn3PwczRvc3p3QjhKakU/games.htm
B
5
S
2
Posts: 12
Reputation: 499

Post » Mon Feb 09, 2015 4:02 am

this is most likely not a c2 bug.Try updating your graphics card as well as all windows updates and browsers are installed . also try turning webgl off as your card may be blacklisted
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Mon Feb 09, 2015 5:57 am

This just happened to me as well. Exported multiple projects. Black screen on chrome.
B
43
S
7
G
6
Posts: 45
Reputation: 4,752

Post » Mon Feb 09, 2015 8:29 am

@Digitizer

The games you link to work for me on IE11 and Firefox,.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
130
S
29
G
80
Posts: 5,270
Reputation: 55,972

Post » Mon Feb 09, 2015 1:52 pm

The games are fine now (1/9/15) but they were definitely not working over the weekend on multiple computers using IE and Windows 7 and 8.1.

I believe that concern is still warranted.
Why did the problem appear and why did it apparently spontaneously disappear with no action on my part??
B
5
S
2
Posts: 12
Reputation: 499

Post » Mon Feb 09, 2015 3:01 pm

Your concern may still be warranted, but it still isn't a C2 bug. It's more likely an issue with your server.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
130
S
29
G
80
Posts: 5,270
Reputation: 55,972

Post » Tue Feb 10, 2015 3:46 pm

Just tested the first game on Chrome and IE11 and it worked fine.

If none of the games on Google Drive were working, the most likely explanation is that Google Drive had some kind of outage. Check the browser error console, or preview from within Construct 2, to check if this is the case.
Scirra Founder
B
386
S
229
G
87
Posts: 24,207
Reputation: 191,592

Post » Tue Feb 10, 2015 4:15 pm

Should it happen in the future, I will do that. Thanks - all is working fine now.
B
5
S
2
Posts: 12
Reputation: 499


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest