Android crosswalk apk version

Ideas and discussion about publishing and distributing your games

Post » Wed Dec 02, 2015 12:55 pm

Hi,

I've used intel XDK to build an APK for google play. When i was uploading the arm version, google gives me a message saying that APK version code must be greater than 14 (i'm translating it, so it could be a bit different in english). This didn't happen with the x86 version, which was uploaded first.

Should i have to change it while exporting the project with Construct 2 by using 4.1+ (Jelly Bean), or may i change it on intel XDK => build settings => minimum android API?

In the Construct 2 export panel the only option with [crosswalk] is the first one 4.0+ (Ice Cream Sandwich), so i really don't know what changes should be the right one. May you guys please clarify it to me?

Thank you!
B
14
S
5
Posts: 110
Reputation: 1,338

Post » Wed Dec 02, 2015 3:44 pm

APK version code is, when building with Crosswalk, a 5-digit number, arm starts with 2 and x86 with 6. You can change it in Intel XDK, under Project Settings -> Build Settings -> App Version Code (here you set 15, if it has to be greater than 14, and increase it every time you publish to Google Play)
B
31
S
7
G
4
Posts: 387
Reputation: 4,544

Post » Thu Dec 03, 2015 1:08 pm

HI grigrizljac,

Thanks for the clarifying and sorry for my reply delay.

This is very strange, cause it is supposed to be the same app version, as one apk is for x86 processor architecture and the other for the ARM. It was my first uploaded app, so it is not an update. Both was generated by Intel XDK at the same time after built. The instructions told me to upload both files to google paly for the sake of compatibility with multiples android devices. So, how could the app version be different?

Best regards!
B
14
S
5
Posts: 110
Reputation: 1,338


Return to Distribution and Publishing

Who is online

Users browsing this forum: No registered users and 0 guests