Android(4.2.1) sound problem

Discussion and feedback on Construct 2

Post » Wed Apr 09, 2014 12:35 pm

Hi, it seems that the problem is not in C2, but i only have 1 android device, and maybe someone have the same problem.
When i run a Construct 2 game, my Android device(4.2.1) goes almost mute,the sound is played very low, and the volume buttons can't control the volume anymore(even in other games and apps like youtube).I have to restart the device to fix the problem.
This happens only when the Audio object is in the project, and the problem occurs when i run the game on chrome for android
I don't know if this is related to this chromium bug?
chromium issue

Can someone clarify this issue for me?
Thanks
Last edited by cesisco on Thu May 15, 2014 11:18 am, edited 1 time in total.
B
36
S
11
G
9
Posts: 399
Reputation: 10,283

Post » Wed Apr 09, 2014 2:52 pm

Are you definitely using Chrome and not the stock browser?
Scirra Founder
B
399
S
236
G
89
Posts: 24,524
Reputation: 195,380

Post » Wed Apr 09, 2014 3:11 pm

Ashley wrote:Are you definitely using Chrome and not the stock browser?


@Ashley, yes i'm using Chrome, and this happens in the final intel apk build from crosswallk for android too, and is not a problem of a specific game but in every project i have the Audio object.Tks
B
36
S
11
G
9
Posts: 399
Reputation: 10,283

Post » Wed Apr 09, 2014 9:21 pm

Sounds like a bug in Chrome rather than a C2 problem. Does it happen in Firefox for Android?
Scirra Founder
B
399
S
236
G
89
Posts: 24,524
Reputation: 195,380

Post » Thu Apr 10, 2014 1:48 am

@Ashley
@cesisco

I think this is Chrome+audio bug or something. The audio is low because it is playing on the earpiece and not on the phone speaker( Galaxy S3, Android 4.3, Latest Chrome not Crosswalk).

On firefox the sound played ok and loud on my phone speaker.
B
83
S
23
G
14
Posts: 389
Reputation: 12,529

Post » Thu Apr 10, 2014 10:08 am

@Ashley
@tumira

It works fine in FIrefox, it seems that is a problem with Chrome.And i guess the bug occurs in Crosswalk too because it is a Chromium based engine.
B
36
S
11
G
9
Posts: 399
Reputation: 10,283

Post » Thu Apr 10, 2014 9:40 pm

had the same issue with my nexus 5 (4.4.2). Still havent found a solution, but the temporary work around for testing etc, is to grab the app called "SoundAbout" which can force audio through different outputs, eg: the speaker. it resolves the problem until a proper solution can be found.
B
87
S
44
G
16
Posts: 1,009
Reputation: 17,946

Post » Sat Apr 12, 2014 4:56 pm

Not sure if this is related, but... on my Samsung Galaxy S3, my Construct 2 app worked fine in Firefox but didn't play sound in Chrome. It did work in Chrome on an iPad. (Very likely a bug in Chrome on Android.) I updated Chrome on my Samsung, then the sound worked.
B
4
G
1
Posts: 5
Reputation: 335

Post » Tue Jul 01, 2014 9:52 am

Bug Solved!;)
B
5
S
1
Posts: 37
Reputation: 453


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 11 guests