Animation does not play

For questions about using Classic.

Post » Thu Apr 28, 2011 9:15 am

Hi,

I see people asking and get replies here so here is mine.



When I press space, The sprite deactivates the platform behavior, plays an animation ("aim")
and everything is OK

When I release space, the animation("aimdown) does not play (or so it seems) and the sprite activates the platform behavior again.

Why can't I see the animation? Does the activation of the behavior stops the animation before it plays? how can I "give some time" to the animation to play, if that's the case?

thanks.

If you need more info, I will post the cap file
B
1
G
1
Posts: 2
Reputation: 429

Post » Thu Apr 28, 2011 3:26 pm

There is an object called the "Wait" object, maybe try adding that and waiting between 1000 and 2000 seconds before re-activating the behavior (other events will still function as normal though).

Otherwise, I'd say it is because the animation isn't timed properly (check the animation speed isn't like 50 times per second). If that's not the case though then it could also be if you use tagged animations, as the platform behaviour will always try to switch those when activated.
"Construct 4 lets YOU make advanced games! (maybe)" Construct Classic - Examples Kit
B
86
S
28
G
13
Posts: 2,092
Reputation: 15,009

Post » Fri Apr 29, 2011 6:02 pm

thanks jayjay.
I must confess that I officially gave up on my project. Even if animations worked ok, there were still issues that I cannot solve using construct. I wanted to do something different but the complexity of the project cannot be mapped in construct. Well, "I" can't do it in construct.

Anyway here are the sprites (in a cap file) if anyone wants to make something. (just erase everything else and keep the sprites)

maybe (yet another) space shooter is easier for me.


[url:158atttq]http://www.mediafire.com/?tn141gbza4jc3hz[/url:158atttq]
B
1
G
1
Posts: 2
Reputation: 429

Post » Fri Apr 29, 2011 6:36 pm

[quote:1aaimdrc]Well, "I" can't do it in construct.[/quote:1aaimdrc]
I used to say that a lot when i first began using Construct , But i quickly learned the work arounds through the patience and tutorials from the good people of Scirra.
B
22
S
3
G
6
Posts: 1,356
Reputation: 7,141


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 9 guests