Animation Finished Bug(Maybe)

Post your own tutorials, guides and demos.

Post » Tue Sep 23, 2008 9:13 pm

I think I found a bug with the animated finished event, but I wanted to run it by everyone to see if I'm doing something wrong before I submit it to the bug tracker:

Animation Finished Bug

When you hit the space bar, the little guy will pop out and shoot, then got back in a again. But if I hit the space bar again, he wont open up again. If I change the 10th event to "if animation "closing" is playing & animation frame is equal to 5," everything runs fine, and I can have him pop out as many times as I want. Is this a bug, or am I doing something wrong?
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Wed Sep 24, 2008 1:11 am

It's not a bug. It has to do with animations stopping when they're not set to "Loop." You have to manually restart them again from frame 1. See this thread for the solution.

Edit: Err, I just remembered that he didn't post his example publicly, he just PM'd me.

I'll try to fix up your example .cap and post the fix. BRB.

Edit 2: Here you go :)
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Wed Sep 24, 2008 1:44 am

Awesome! Thanks. :) I think this probably needs to be changed to where non looping animations are automatically changed back to the first frame after you switch to a different one, though.
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Wed Sep 24, 2008 2:10 am

Ashley has said a number of times improvements will be made to the animation set up. I'm sure we'll get a much better configuration eventually :)
B
2
S
2
G
5
Posts: 391
Reputation: 2,432


Return to Your tutorials & example files

Who is online

Users browsing this forum: No registered users and 2 guests