Animation Issues

Get help using Construct 2

Post » Thu Dec 20, 2012 8:01 am

Hello,

I'm trying to make my character play the hit and slide animation when
clicked on the icon but it keeps playing the running animation because I made it play running animation when on collision of the floor.
I'm unsure on how to make the character play these animations for like 1 second or so and then keep running after the animation.

Here is the capx for a reference: http://dl.dropbox.com/u/75406771/runforit.capx
Hobby app website: http://www.skymillapps.com/
B
10
S
2
Posts: 105
Reputation: 2,114

Post » Fri Dec 21, 2012 6:15 am

bump~
Hobby app website: http://www.skymillapps.com/
B
10
S
2
Posts: 105
Reputation: 2,114

Post » Fri Dec 21, 2012 6:44 am

Fixed capx (made in r113)

I've had to set the "run" animation to loop, add a boolean instance variable to the "run" object..
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Post » Fri Dec 21, 2012 6:29 pm

Is it possible if you can help me make it so when I hold hit, It keeps playing hit animation without interference?
I tried to change the control to 'hold touch' but it still flashes to the running animation when I hold the hit icon.
Hobby app website: http://www.skymillapps.com/
B
10
S
2
Posts: 105
Reputation: 2,114


Return to How do I....?

Who is online

Users browsing this forum: CavalierBubble, Evanetot and 17 guests