Animation problem

Get help using Construct 2

Post » Fri Jan 20, 2017 11:40 pm

Hello everyone!

I'm really new to C2 so I don't know quite a few stuff but I'm learning.

I've come across a problem with animation, all is working really good until the character hits a wall or a platform he has to jump on. Instead of stopping the characters seems to be stuck in a running animation, repeating itself rapidly, making the character looking like he's spazzing out a bit. If anyone knows the solution I'd be most grateful.

Regards,

Vilin13
B
4
Posts: 6
Reputation: 214

Post » Fri Jan 20, 2017 11:44 pm

Try:

Character - On collision with wall > Character - Set animation to (make a single frame or an idle animation and set it to that)

Or maybe even try Offset. Which means if the character is X pixels away. (choose how many pixels)
B
38
S
18
G
19
Posts: 664
Reputation: 14,107

Post » Fri Jan 20, 2017 11:54 pm

Thanks for the answer, another question though... How do I do this with a tilemap? Idle animation works, but since the tilemap is apparently seen as one object it just stays idle all the time and doesn't proceed to run animation :/
B
4
Posts: 6
Reputation: 214

Post » Sat Jan 21, 2017 12:01 am

Could put invisible walls on the sides.
B
38
S
18
G
19
Posts: 664
Reputation: 14,107

Post » Sat Jan 21, 2017 12:08 am

Right, didn't think of that. Thank you very much!
B
4
Posts: 6
Reputation: 214


Return to How do I....?

Who is online

Users browsing this forum: Google [Bot] and 14 guests