Animation Problems

For questions about using Classic.

Post » Thu Oct 07, 2010 9:29 am

I don't know if it is just me or something, but I ALWAYS have problems with getting animations to work right. I am having an especially difficult time right now, I am trying to change the animation state of a gun on my character, but instead of it changing it wants to be all stubborn. I have tried so many things. I have renamed the animation, I have made a new animation, I have edited the animation, I have tried changing up the sequence it is called in. I don't know what to do. Does anyone else have animation problems? And if so how do you deal with them?
B
2
G
3
Posts: 46
Reputation: 942

Post » Thu Oct 07, 2010 10:19 am

Animation problems are quite common. Unfortunately it's also common to post about a vague problem without even providing a cap file demonstrating it. I would have to guess, since I can't see the events you're using to control your animations.

So please provide a cap. I'm positive it'll be a pretty simple problem. But I'd rather not guess... :P
B
21
S
6
G
10
Posts: 1,024
Reputation: 7,445

Post » Thu Oct 07, 2010 6:51 pm

I had a feeling someone would need to see the .cap. I was just wary of posting it, but since that is what is needed, I shall.

Basically I have it something like this.
[code:2ct1w8ib]If gun = holstered
gun animation = holstered[/code:2ct1w8ib]

At first, it would only play the holstered animation. Now it won't play the holstered animation.
It's under the group combat, under the group weapons, under the group Falcon, under the group Holstered.

[url:2ct1w8ib]http://www.megaupload.com/?d=DHX5DQXM[/url:2ct1w8ib]


I forgot the controls. Sorry.
W switches weapons, A and D move, Shift jumps, Mouse to aim, Left click to shoot.
B
2
G
3
Posts: 46
Reputation: 942

Post » Thu Oct 07, 2010 9:18 pm

Event #16 under Combat\Weapons\Falcon:
[code:3jm2zgxo]+ psidea: Value 'name' Equal to "Falcon"
-> psidea: Set animation to "Falcon"
-> psidea: Set 'recoil' to 4
-> psidea: Set 'reloadtime' to 17
-> psidea: Set 'mmag' to 12
[/code:3jm2zgxo]
The event is always true so the animation is always getting set to "Falcon" overriding any animation changes. Removing the action "-> psidea: Set animation to "Falcon"" will fix it.
B
79
S
24
G
54
Posts: 4,749
Reputation: 40,761

Post » Thu Oct 07, 2010 10:10 pm

I feel stupid now. I should have seen it. I fixed that, and it worked at first but now it goes back to being stubborn after I change up the weapons once.

When everything starts the animation is correct, but I swap weapons once and my gun is on my foot again :(
B
2
G
3
Posts: 46
Reputation: 942


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 8 guests