Animation sticking problem

For questions about using Classic.

Post » Sun Oct 02, 2011 10:15 pm

Hey,

My first post here, I only found out about this program about 2 days ago and I've spent the past day or so reading tutorials, getting some ideas together and building sprites etc.

I managed to get the animations to work for the grid style system. That includes walking up, down, left and right, idle animations in all directions and a sprinting(left and right only).

The character can sprint by pressing down the left control button, but when you release control and keep the WASD buttons down, the character is still showing the sprinting animation. What I'd like is that when you release control, but still hold WASD, the animation goes back to walking in the held direction.

I'll upload a copy of the file so anybody can check it out and hopefully help me out and give me some pointers. It's rough as hell, so there's probably a few problems.

Thanks guys!

Link to file

By the way, I'm aware that this problem may have happened to many people before and it'd be better to search for it. I've been searching the forums all day and have yet to find anything suitable though :-/jstick2011-10-02 22:23:20
B
3
G
1
Posts: 2
Reputation: 779

Post » Mon Oct 03, 2011 3:25 am

Here you go http://db.tt/Jwd2j39D
B
12
S
2
G
2
Posts: 96
Reputation: 1,583

Post » Mon Oct 03, 2011 1:10 pm

Thanks buddy, that works great! The events make a lot more sense that way too.
B
3
G
1
Posts: 2
Reputation: 779


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests