Animations Problem

For questions about using Classic.

Post » Mon May 12, 2008 7:29 pm

Can anyone explain to me why the animations for the player aren't... well playing?

Cap File.
B
2
S
2
G
4
Posts: 136
Reputation: 1,722

Post » Mon May 12, 2008 7:36 pm

Maybe I'm missing something, but you never change the animation to Walking.

A good addition to the Behaviors would be to set default animations for moving etc, but for now you have to change animations manually.
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Mon May 12, 2008 7:55 pm

But I did set it to walking... in PlayerControls. Or am I missing something?
B
2
S
2
G
4
Posts: 136
Reputation: 1,722

Post » Mon May 12, 2008 7:59 pm

You're right I missed it.

I don't know why it doesn't change animation; if I just try

Mouse&Keyboard: Key Right arrow is down
> System: Close application

it doesn't close the application..
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Mon May 12, 2008 8:04 pm

I'm going to guess that this goes back to the issue with the mouse & keyboard object not transferring over. I'm going to try making a new mouse & keyboard object and see if it works.
B
2
S
2
G
4
Posts: 136
Reputation: 1,722

Post » Mon May 12, 2008 8:07 pm

Yeah that's exactly it. Apparently after a save and then re-open of the file the system no longer picks up the old mouse & keyboard. :x

So... there's another bug for ya.
B
2
S
2
G
4
Posts: 136
Reputation: 1,722


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests