Another clue to the tile jitter issue...

New releases and general discussions.

Post » Tue Apr 01, 2008 9:04 pm

I found out about this just today! Like five seconds ago!

You know the tile jitter issue that was plaguing my game on some people's computers... apparently Game Maker has the very same issue:

[quote="From another forum":1cjz37g1]
I find the best way to maintain a nice retro look in a scrolling game in Game Maker is to set the View Sizes like Hideous suggested earlier.

What you do is set the view to something like 319 x 239 and then set the view port 799 x 599, if I remember correctly. The reason for the one pixel off is to fix a bug that exists in GM6 amd 7 that occurs with certain NVidia cards that leaves a blank pixel between tiles when the port is scaled. Strange stuff. Let me know if that works out for ya.
[/quote:1cjz37g1]

That's the same bug! But obviously it doesn't occur in every game-making program, because it would be a more commonly known issue.

So Ashley, what are your thoughts on this? Is this a reparable issue in Construct? Or is it just something that's always going to be there because of certain hardware?
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Tue Apr 01, 2008 11:15 pm

I think it's more likely a bug in Construct until I properly research the bug, in which case it would be coincidence Game Maker has this bug.

If it is a problem with nVidia cards, I can't and won't do anything about the bug. In that situation it would be nVidia's problem so if the latest drivers still had the problem, you'd have to go complain to them about it. Right now though, can't say which it is. We'll see.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Tue Apr 01, 2008 11:22 pm

Hey, I am using an ATI Radeon X700pro and I can confirm this problem does happen for me. I was going to mention it earlier, but I usually don't have the time. Anyways, just thought I would mention that.
B
2
S
1
G
5
Posts: 54
Reputation: 1,508

Post » Tue Apr 01, 2008 11:23 pm

Thanks Exomarc, confirms my suspicion it's my fault ;)
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Tue Apr 01, 2008 11:34 pm

[quote="Ashley":2t7k4ts2]Thanks Exomarc, confirms my suspicion it's my fault ;)[/quote:2t7k4ts2]

Ah, well I suppose that's good news of a sort. That means that likely it's fixable. Hopefully it's not a terribly troublesome fix. Good luck with it :)
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Wed Apr 02, 2008 5:48 am

... That was from TIG right? I seem to remember saying something about views, haha.
B
2
S
2
G
4
Posts: 110
Reputation: 1,670

Post » Wed Apr 02, 2008 6:01 am

Yep. That's about the only other forum I post on any more. Sometimes SA, but it's gone downhill big time.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Wed Apr 02, 2008 6:03 am

I'd join SA, but it costs money. It costs money to join a forum. Sheesh.
B
2
S
2
G
4
Posts: 110
Reputation: 1,670

Post » Wed Apr 02, 2008 6:20 am

[quote="Hideous":xslpvc24]I'd join SA, but it costs money. It costs money to join a forum. Sheesh.[/quote:xslpvc24]

At one time I would have said it was worth it. That was a few years ago. And back then it really was.

Eh, I don't mind having given them ten bucks (at least back then I had a job :P ). I got ten bucks worth of enjoyment out of that place a thousand times over. It's just that there are a lot of idiots around there now, and everyone seems to be rehashing the same old tired in-jokes and cliches. Plus I mainly joined to take part in Photoshop Phriday, and I did for a long time, but I just sorta got tired of photoshop. I did make the front page three or four times, though 8)
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Wed Apr 02, 2008 6:38 am

Yeah, Photoshop Phriday was actually the main reason I wanted to join.
B
2
S
2
G
4
Posts: 110
Reputation: 1,670

Next

Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 2 guests