Another problem with Saved games

Get help using Construct 2

Post » Sun Sep 30, 2012 8:12 am

Thanks for following up Weishaupt, what you said in your last post made me think of something. trying it now will post back if it works.
B
48
S
15
G
5
Posts: 183
Reputation: 8,476

Post » Sun Sep 30, 2012 8:20 am

A closer look at the cookies retrieved the following:

CREATE TABLE ItemTable (key TEXT UNIQUE ON CONFLICT REPLACE, value BLOB NOT NULL ON CONFLICT FAIL)

...so it seems to be an error in your code!
B
42
S
19
G
12
Posts: 723
Reputation: 13,911

Post » Sun Sep 30, 2012 2:46 pm

You're not loading the ArrayPow array. When you click the load button you set Layout to ArrayPow.At(1,2) and VX to ArrayPow.At(2,2) etc. but you haven't loaded the ArrayPow array from webstorage so all thoses values are 0.
B
54
S
28
G
18
Posts: 1,520
Reputation: 24,990

Post » Mon Oct 01, 2012 10:28 am

Thanks ramones and Weishaupt, I finally got it working. Much appreciated
To get it working I needed to clear storage, then I disabled the ArrayPow actions from the save button and the system > set ArrayPow from the load button and it works now.:)

Final question, how would I load ArrayPow from Webstorage? I looked at the manual and I'm still confused. Sorry for the noob questions. Regardless it's working well from what I can see, I just want to understand better. Thanks again , both of you:)MelVin2012-10-01 10:29:06
B
48
S
15
G
5
Posts: 183
Reputation: 8,476

Previous

Return to How do I....?

Who is online

Users browsing this forum: LeFuji, qaisarehman, Yahoo [Bot] and 22 guests