Any way to increase responsiveness of construct 2?

Chat about anything not covered in these forums, but keep it civil!

Post » Thu Nov 21, 2013 1:23 pm

Hi iv'e been using construct for a game for a while now. pumped 600+ hours into it and for about a month now the engine becomes very unresponsive.

When I double click events they take a short while to open or I have to click the construct window tab at the bottom for it to show up.

Everything can become really unresponsive and minimizing and maximizing the window is needed to refresh black screens.

It happens fairly often now usually every session, does anyone know the main reason I have these problems?

Perhaps some reasons may be:

I have got a fair few of the plugins from the forums.

I have 50 layouts up to yet.

The game runs fine ingame it's just when making it with construct 2 I get the problems.
B
12
S
4
G
1
Posts: 137
Reputation: 1,519

Post » Thu Nov 21, 2013 1:54 pm

How many Layouts and Event Sheets have you got open?

How many Objects have you got on the Layouts?zenox982013-11-21 13:56:04
If your vision so exceeds your ability, then look to something closer.
Moderator
B
136
S
31
G
86
Posts: 5,483
Reputation: 59,752

Post » Thu Nov 21, 2013 2:16 pm

if open you mean tabs at the top I usually only have 4-5 open at once.

layout objects wise changes per map but around 30 different objects per map and lots of instances of most. Maybe a few hundred on some maps.
B
12
S
4
G
1
Posts: 137
Reputation: 1,519

Post » Thu Nov 21, 2013 4:46 pm

I have also come across this problem...

C2 on some occasions seems to lag, if I click the action or event box there is a 1-2sec delay before it opens, if I start typing in an input box there is around a 1/4sec delay between each letter appearing on the screen.

I then have to minimize C2 and maximize it to get it to return back to normal.

Unfortunately I haven't been unable to find the cause of this problem.

It isn't connected to the size of the project either, only yesterday I was making a small prototype game approx 20 stationary sprites and 60 events and had the same problem...

At least the minimize maximize trick works
B
8
S
3
G
1
Posts: 34
Reputation: 1,395

Post » Tue Nov 26, 2013 4:14 pm

Black screens ? Sounds like graphic driver issues.
Update yours and make sure to use a decent graphic card and not just graphic chipset from the motherboard.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
293
S
117
G
96
Posts: 7,310
Reputation: 71,069

Post » Tue Nov 26, 2013 4:22 pm

If you can reproduce any issue reliably, please submit it as a bug report and we'll take a look. Perhaps the latest betas are better as well?
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,361


Return to Open Topic

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest