Anyone else notice Node Webkit Bad Performance?

Discussion and feedback on Construct 2

Post » Tue Dec 23, 2014 8:36 am

Ever since I upgraded to the November 25th release, NW has been performing horribly. Like on my title screen I'm only getting roughly 30FPS when I was getting 60 prior. Now I see this as a blessing in disguise because it means I can optimize my game more than I could without the issue but now it's just getting annoying.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Tue Dec 23, 2014 9:11 am

I updated from 184 to 191 and have same issue, very poor performance, but don't know if it has to do with node webkit, I get still 60FPS but screen still stutter when scrolling :(
B
47
S
10
G
5
Posts: 110
Reputation: 3,907

Post » Tue Dec 23, 2014 10:08 am

Well I found a boon to my game's performance by disabling force own texture in places it was enabled and not needed and using render cells but the frame rate still is kinda choppy.

Don't know why force own texture was enabled so much.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Tue Dec 23, 2014 10:10 am

There are a number of forum posts regarding Chrome's performance at the moment. This of course has an effect on Node too.
B
51
S
16
G
9
Posts: 1,098
Reputation: 11,252

Post » Tue Dec 23, 2014 11:17 am

Oh there are? I tried searching for them but only found one written a month ago and didn't want to post on an old thread that had died. Well I guess it's good to know it's not just me. :)
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Tue Dec 23, 2014 5:31 pm

Just tested it on ie and chrome and its bot choppy. All static layers use render cells to improve performance but still choppy.
B
47
S
10
G
5
Posts: 110
Reputation: 3,907

Post » Tue Dec 23, 2014 6:00 pm

B
47
S
10
G
5
Posts: 110
Reputation: 3,907

Post » Wed Dec 24, 2014 4:02 am

Thanks. One thing I noticed that's really screwing up performance is webgl effects for sure.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Wed Dec 24, 2014 5:01 am

If you have multiple objects using the same webgl effect, even if they're the same object but multiple instances, if you can put them on their own layer and apply the effect to the layer rather than the objects, it should have better performance. That way the effect is only applied once rather than multiple times.
B
48
S
23
G
66
Posts: 1,144
Reputation: 39,059

Post » Wed Dec 24, 2014 6:16 am

While that's true, actually the issue I'm having is the more a webgl effect covers the screen the worse my performance gets on this version of Node Webkit, didn't have this problem before.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 17 guests