APK upload denied at Google Play (CocoonJS plugin)

Discussion and feedback on Construct 2

Post » Sat Aug 02, 2014 6:49 pm

Hi Guys,

Not sure whether this is construct related or something for ludei / cocoonjs team (or maybe problem i have to fix myself?)

I have a game which contains IAP (in app purchases) via the cocoonjs plugin that's in Construct R175.
This works quite good but .... since 1-aug-2014 I'm not able to upload my new build APK's to google anymore.

It reports that It's not allowed due to version 4242000 of google play-services which are used.
It also reports that minSdkVersion needs to be 9 or up.

Is there something i'm doing wrong or needs to be updated on my side?

cheers
//Xam
Last edited by Xam on Sun Aug 03, 2014 7:29 pm, edited 1 time in total.
B
8
S
2
Posts: 24
Reputation: 694

Post » Sat Aug 02, 2014 11:37 pm

the advertising ID of google play services is the problem, but i dont know how to solve this either
since there is no place on cocoon where we can enter the ID
any one can help ?
B
24
S
4
G
2
Posts: 45
Reputation: 2,403

Post » Sun Aug 03, 2014 8:45 am

Same problem here
B
7
S
2
Posts: 140
Reputation: 1,073

Post » Sun Aug 03, 2014 7:31 pm

Furdy wrote:Same problem here


Only with banners / advertisement or with IAP?
B
8
S
2
Posts: 24
Reputation: 694

Post » Sun Aug 03, 2014 9:15 pm

Ok I think Ludei fixed it. What I did to resolve this issue.

Check the minimal version on CocoonJS website (under projects > Settings > Android) which should be 2.3
Recompile using version 2.0.2

Now I'm able to upload my APK's again, Yay!
B
8
S
2
Posts: 24
Reputation: 694

Post » Tue Aug 05, 2014 4:05 pm

Im late to the party but this is because Admob (Google) now, since August 1st, requires "minSdkVersion = 9" which is Google Play friendly. I had the same errors updating apps over the weekend (native android apps not CS2 apps) and had to use the '9' in the manifest xml.
B
15
S
2
Posts: 229
Reputation: 1,353

Post » Wed Aug 06, 2014 2:33 am

Just to clarify for everyone. Make sure you use a minimum of 2.3.3 in the Android options of the cloud compiler.

Image

I ran into the same issue over the weekend :).
B
101
S
32
G
11
Posts: 1,552
Reputation: 21,667

Post » Wed Aug 06, 2014 11:37 am

If I put another version of android, I will have problems then?
B
12
S
3
G
1
Posts: 188
Reputation: 1,377

Post » Wed Aug 06, 2014 12:03 pm

vitorfgd wrote:If I put another version of android, I will have problems then?


No, all versions above 2.3 should work ( it seems it is not possible to select a version < 2.3 anymore anyway)
B
8
S
2
Posts: 24
Reputation: 694

Post » Wed Aug 06, 2014 12:18 pm

Xam wrote:No, all versions above 2.3 should work ( it seems it is not possible to select a version < 2.3 anymore anyway)


Thanks for the clarification, I have only used from version 3.0, for performance reasons, devices with android lower than this are very limited
B
12
S
3
G
1
Posts: 188
Reputation: 1,377

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 9 guests