App disappearring on Firefox

Bugs will be moved here once resolved.

Post » Thu Jul 11, 2013 8:47 am

Steps to reproduce:
1. Create new project
2. Add a textbox and a button
3. Launch it with Firefox

Observed result:
Since last Construct 2 version, everything disappear on firefox several seconds after launching app. Only textboxes, buttons or such objects stay visible. When an action occur (like click on a button), everything reappear.

Expected result:
No disappearing.

Browsers affected:
Chrome: no
Firefox: yes - Everything is up-to-date, tested with no addons.
Internet Explorer: no

Operating system & service pack:
Windows 7 Home, last update

Construct 2 version:
Release 132 (64-bit)    
B
7
S
1
G
3
Posts: 46
Reputation: 1,731

Post » Thu Jul 11, 2013 4:46 pm

Closing - please follow the bug report guidelines and attach a .capx.
Scirra Founder
B
382
S
223
G
85
Posts: 23,987
Reputation: 189,521

Post » Fri Jul 12, 2013 12:10 am

Why would you need a specific .capx for such a bug here? :(
B
7
S
1
G
3
Posts: 46
Reputation: 1,731

Post » Mon Jul 22, 2013 2:12 pm

This is a real bug, only on Firefox. Juste make any app and launch on Firefox. Easy to replicate...
Ok here is a capx, if really needed...
App disappears
B
7
S
3
G
1
Posts: 5
Reputation: 1,710

Post » Mon Jul 22, 2013 2:34 pm

It does stop rendering, but if you add an event that solves it.
... so not really a bug.
Image ImageImage
B
165
S
49
G
147
Posts: 8,041
Reputation: 96,574

Post » Mon Jul 22, 2013 3:03 pm

You mean, if there is nothing happen, it's normal that the app simply disappear ? That sounds but a bit strange. In Chrome the app doesn't disappear.Daidy2013-07-22 15:39:44
B
7
S
3
G
1
Posts: 5
Reputation: 1,710

Post » Mon Jul 22, 2013 3:58 pm

Well do you see some circumstance where the user would publish without any events?
Image ImageImage
B
165
S
49
G
147
Posts: 8,041
Reputation: 96,574

Post » Mon Jul 22, 2013 5:32 pm

The problem occurs even if there are some events, see the example updated. And yes, there are many examples where the game renders nothing more and simply waits for a response of the user.
So again, I don't think it's normal that an app arbitrary disappears...Daidy2013-07-22 17:39:43
B
7
S
3
G
1
Posts: 5
Reputation: 1,710

Post » Mon Jul 22, 2013 8:43 pm

Ok it stops rendering with the every x seconds event.
I guess that's because there's nothing to draw.
So I stand corrected, it is a bug.
Image ImageImage
B
165
S
49
G
147
Posts: 8,041
Reputation: 96,574

Post » Tue Jul 23, 2013 7:20 pm

You're right, that's because there's nothing to draw.
I tried adding a moving sprite and setting it invisible, the app non longer disappears. But it's an ugly trick.
B
7
S
3
G
1
Posts: 5
Reputation: 1,710

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests