App disappearring on Firefox

Bugs will be moved here once resolved.

Post » Tue Jul 23, 2013 7:20 pm

You're right, that's because there's nothing to draw.
I tried adding a moving sprite and setting it invisible, the app non longer disappears. But it's an ugly trick.
B
7
S
3
G
1
Posts: 5
Reputation: 1,710

Post » Mon Aug 05, 2013 3:51 am

Glad to see I'm not the only one, I'm not insane !
B
7
S
1
G
3
Posts: 46
Reputation: 1,731

Post » Mon Aug 05, 2013 8:26 am

I've noticed that too, and apparently it's indeed specific to FireFox.
Putting some sprite out of the layout with a sine behavior for example does the trick and make it so that the rendering doesn't disappear anymore.Having a sprite with an animation of several frames does the trick too.

If your project is only composed of a text object, the rendering works as intended.
From the moment you add a one frame sprite to it, the rendering will eventually disappear after a few seconds.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
289
S
112
G
94
Posts: 7,333
Reputation: 69,293

Post » Mon Aug 05, 2013 5:26 pm

This issue is specific to Firefox. You should report it to Mozilla.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,772

Post » Mon Aug 05, 2013 6:06 pm

Actually scratch that, I found it reproduced with one of our old demos and posted a bug for it here: https://bugzilla.mozilla.org/show_bug.cgi?id=901574
Definitely a Firefox bug by the looks of things.Ashley2013-08-05 18:06:27
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,772

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest