App exported for Ejecta shows a black screen on iPhone 5

Bugs will be moved here once resolved.

Post » Mon Dec 22, 2014 1:10 pm

Problem Description
____ A concise description of your problem here ____

A newly created Construct 2 simple page is exported to Ejecta.

I follow the instructions found at https://github.com/phoboslab/Ejecta and I download the Ejecta source. I run it on an iphone and it is working ok.

When I substitute the index.js file with the one from the Construct project I get a blank screen and no specific error or warning.


Attach a Capx
____ Upload a Capx to this post ____

Description of Capx
____ Concise description of what this CapX does ____

Steps to Reproduce Bug
  • Download the Ejecta source and run it as an iPhone project, it works ok
  • Substitute index.js with the file generated by exporting the capx to Ejecta.
  • Build and run on a device

Observed Result
____ What happens? ____
The app run on the iPhone shows a blank screen

Expected Result
____ What do you expect to happen? ____
The app run on the iPhone should display the screen's orange image

Affected Browsers
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
____ Your operating system and service pack ____
iOS 8

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____
Release 190 (64-bit)
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 1
Reputation: 252

Post » Mon Jan 05, 2015 4:33 pm

Closing as won't fix: as of r192 we no longer officially support Ejecta. Consider using Cordova instead, or if you are desperate, file a bug with Ejecta instead.
Scirra Founder
B
395
S
231
G
88
Posts: 24,367
Reputation: 193,694


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests