arcade crashing on safari

If you have found a bug, or have a suggestion/comment then leave it here

Post » Mon Dec 24, 2012 4:42 pm

I'm not sure if this is a Website issue or a construct 2 issue but some of the games on the arcade seems to crash Safari Version 6.0.2 (7536.26.17). When they do they usually get about half way loaded then the browser is closed with an error log.Ethan2012-12-24 16:42:35
B
37
S
19
G
18
Posts: 613
Reputation: 10,231

Post » Sat Mar 02, 2013 8:24 pm

Our team is having the same problem. Two of our games posted on FGL for review before the bidding process starts were denied on the grounds that it wasn't running on the newest OSX Mountain Lion with the newest Safari (HTML5 export).

I'm not currently up to the same os version as that or Safari version, but I had some helpful insight from a developer on site. Here's some of the stack reports:


[code]
0   com.apple.JavaScriptCore          0x0000000107a7da67 dfgConvertJSValueToBoolean + 119
1   ???                               0x0000000109861000 0 + 4454748160
2   com.apple.JavaScriptCore          0x00000001079aeec0 JSC::Interpreter::executeCall(JSC::ExecState*, JSC::JSObject*, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 912
3   com.apple.JavaScriptCore          0x00000001079aeb24 JSC::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 52
4   com.apple.WebCore                 0x0000000108517b11 WebCore::JSCallbackData::invokeCallback(JSC::JSValue, JSC::MarkedArgumentBuffer&, bool*) + 593
5   com.apple.WebCore                 0x00000001085d3c73 WebCore::JSRequestAnimationFrameCallback::handleEvent(unsigned long long) + 275
6   com.apple.WebCore                 0x0000000108771feb WebCore::ScriptedAnimationController::serviceScriptedAnimations(unsigned long long) + 187
7   com.apple.WebCore                 0x00000001082d704d WebCore::DisplayRefreshMonitor::notifyClients() + 93
8   com.apple.JavaScriptCore          0x0000000107998dfa WTF::dispatchFunctionsFromMainThread() + 266
[/code]            


We've both tested this in other versions of Safari and Chrome, in Windows and OSX with no luck in reproducing this. Maybe the above info could help, but I honestly think it's Safari being a chump.


Paul
B
17
S
5
G
4
Posts: 24
Reputation: 4,039

Post » Tue Mar 05, 2013 11:31 pm

http://www.google.com/intl/en_uk/mac/

Not sure how to fix it, but in the mean time use this browser instead of Safari. Cheers.
B
12
S
3
G
1
Posts: 15
Reputation: 858


Return to Website Issues and Feedback

Who is online

Users browsing this forum: MrEmixam and 2 guests