@Ashley (Fixed Bug Report)

Bugs will be moved here once resolved.

Post » Fri Sep 26, 2014 10:06 am

Once you open this look for the 2 blank objects with the default name sprites @Ashley. Those were the two objects causing the game to crash. Take a look at those and what they are doing and see if you can tell what happened. My conclusion was deleting the sprites and relaunching. This fixed everything.

Problem Description
-Crashes on launch

Attach a Capx
-capx

Description of Capx
Simple testing of animations, environment objects, and character movements.

Steps to Reproduce Bug
  • Launch the Capx
  • Should immediately get the error code

Observed Result
On launch of Capx Scirra pops up the bug window instantly.

Expected Result
The game should launch fine.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 7 SP1

Construct 2 Version ID
Beta Release (r181) at the time. I also used the Stable Release to test it and got the same results.
Last edited by Apox Inc on Mon Sep 29, 2014 9:13 pm, edited 2 times in total.
B
12
S
3
G
1
Posts: 109
Reputation: 1,979

Post » Fri Sep 26, 2014 12:59 pm

Sorry, nothing we can do here - it's just a project with a missing PNG file (frame 0 from "default" animation in "Sprite"). We need to know how to reproduce this problem in the first place. There's no useful information in the project itself or that error message, it is all a consequence of a file that has gone missing. Please also *always* follow the full bug report guidelines, our policy is to close without investigation any reports that don't follow the guidelines - usually, all of that information is essential (particularly in this case "steps to reproduce").
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Fri Sep 26, 2014 6:17 pm

@Ashley Figured it out myself. I had 2 blank sprites in the object types I forgot to delete which was causing it to attempt loading them and their frames with no source.

FIXED
B
12
S
3
G
1
Posts: 109
Reputation: 1,979

Post » Fri Sep 26, 2014 7:20 pm

Forgetting to delete an object should not cause a PNG file to go missing from the project. I think you must have done something else.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Sun Sep 28, 2014 12:28 pm

Ashley wrote:Forgetting to delete an object should not cause a PNG file to go missing from the project. I think you must have done something else.


@Ashley you misunderstood me. I had 2 sprites that had no image. They were just blank sprites. Therefor it had nothing to read for those sprites. It crashed on export and on relaunch I just clicked retry, deleted the blank sprites, and everything was back to normal.
B
12
S
3
G
1
Posts: 109
Reputation: 1,979

Post » Sun Sep 28, 2014 5:17 pm

@Apox Inc - that should still not cause a problem - please report a bug with the full steps on how to reproduce that so we can fix it.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Mon Sep 29, 2014 3:21 am

Ashley wrote:@Apox Inc - that should still not cause a problem - please report a bug with the full steps on how to reproduce that so we can fix it.


@Ashley when I deleted the blank sprites it started working again. I will write a step by step on what happened. I will edit the original post with the correct form. I'm quite sure this was my own error rather than a system bug.
B
12
S
3
G
1
Posts: 109
Reputation: 1,979

Post » Mon Sep 29, 2014 9:12 pm

@Ashley I have repaired the original post if you would like to take a look at that. Also on the topic of that conversation with nickydude, he got an attitude when I said it seemed his topic was a bug. So I just edited my post with no need to be a d**k. Idk what it was all about but I am glad you locked that. What I said about in the last post is not true to all, so if it offended you I do apologize, just know I was referring to people like him.
B
12
S
3
G
1
Posts: 109
Reputation: 1,979

Post » Tue Sep 30, 2014 11:59 am

@Apox Inc - please post a new thread in the Bugs forum, this report was already closed and editing the first post to something different means the thread no longer makes any sense which can make it very confusing to deal with
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Tue Sep 30, 2014 12:17 pm

@Ashley just forget it lol
B
12
S
3
G
1
Posts: 109
Reputation: 1,979


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests