Assigning Right and Left Triggers on gamepads not working.

Bugs will be moved here once resolved.

Post » Sat Jul 26, 2014 4:06 pm

Problem Description

There seems to be an issue with assigning actions to the Right Trigger using a gamepad.

I tried to set a Parry/Block animation to the right trigger of a gamepad, and when I ran the layout, nothing happened.

I then noticed that when I pressed up on the Right analog stick, the action I assigned to to right trigger occurred.

I switched the even from "On button pressed" to "while button is down," and the same issue persisted.

I wondered if it was my gamepad, so I switched the event from "Gamepad 0" to "Gamepad 1," while I had a second gamepad plugged in and functioning, and the right trigger did nothing on the second gamepad.

I also tried switching the event to trigger on the left triggers of each gamepad, and nothing occurred, however when I switched the event to a button (y or b) or the left and right bumpers, the ParryBlock animations were triggered properly.

Attach a Capx

This is the Capx for my project: https://www.dropbox.com/s/szjxvd9fohbx0vz/Controller%20Bug.capx

Description of Capx

I only have one event sheet, and the specific event is number 24, under group "Player1Controls" I starred the specific event.

I'm creating a beat 'em up, and I want the right trigger to initiate a Parry to Block animation. for each character. I was starting to assign the animation itself to the first player when I noticed it wasn't responding.

Steps to Reproduce Bug
  • Start computer with gamepads plugged in.
  • Open Capx.
  • Run Layout
  • Press Right Trigger

Observed Result

Nothing happened, when it should initiate animation "ParryBlock" for object "Greatsword" With variable value "Instance" the same as Object "PlayerBox1."
Each of the other assigned actions to the gamepad are functioning.

Expected Result

Player1 (blue) should perform animation "ParryBlock."

Construct 2 Version ID

Release 173 (64-bit), running Windows 8.
B
9
S
2
Posts: 37
Reputation: 739

Post » Mon Aug 04, 2014 3:49 pm

Closing, your project has 100 events so there is little evidence it's a bug in Construct 2 and not a mistake in your events. Please follow the guidelines and submit a minimal .capx made from scratch demonstrating the problem if you want it to be investigated further.
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,155

Post » Thu Aug 07, 2014 9:00 pm

Ashley wrote:Closing, your project has 100 events so there is little evidence it's a bug in Construct 2 and not a mistake in your events.


Okay. I'll resubmit. Didn't realize I needed to have a small number of events to report a bug. Sorry about that.

I do feel that the fact that, by simply replacing the only event which references LT/RT to reference a difference button you can get the event to work, would indicate it's an issue, but I understand why having 100 events would be too many to look through to verify this. I'll try to make a smaller, simpler evidence of this.
B
9
S
2
Posts: 37
Reputation: 739


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests