Audio causes Android browser to hang (r178)

Bugs will be moved here once resolved.

Post » Thu Aug 28, 2014 6:36 pm

Repost as per rules.

Problem Description
Add the audio object to a C2 file, add an audio file - the game will not load on the native browser on Android devices.

Also seen in this terribly, terribly recorded video:

https://www.youtube.com/watch?v=Uyj5t0u ... e=youtu.be

Attach a Capx
Attached.

Description of Capx
____ Concise description of what this CapX does ____

Steps to Reproduce Bug
Add the audio object to a C2 file, add an audio file, hit preview over LAN or host online. Open in Android browser.

Observed Result
Literally nothing. The game hangs at the loading screen.

Expected Result
Something.

Affected Browsers
Native Android browser, Chrome is unaffected.

Operating System and Service Pack
The mobile device I am using is a HTC Desire HD running Android v2.3.5 (Gingerbread), whilst out of date this is primarily for legacy compatibility, my employer has the same issue on what I can only assume is the latest Android software and hardware, but I can check if needed.

Construct 2 Version ID
r178

Notes:
The audio object alone doesn't break the project, but adding audio files will, I will try later with different files, but for now I am using one from the Asset Bundle.
You do not have the required permissions to view the files attached to this post.
B
59
S
21
G
9
Posts: 641
Reputation: 9,787

Post » Thu Sep 04, 2014 2:37 pm

I can't reproduce on a Samsung Galaxy S3 running cyanogenmod. I think it's to do with audio preloading, and the Android stock browser has poor audio support, so it may be unable to report the preloaded status correctly. Can you confirm by turning off 'Preload audio' in project properties and seeing if it works again on an affected device?

Either way I've turned off audio preloading for the Android stock browser for the next build, since I can believe it is too crappy to work (that browser is a nightmare... please encourage everyone to get Chrome for Android instead!)
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,772

Post » Thu Sep 04, 2014 7:45 pm

Disabling preload audio fixes the issue! Thanks Ashley
B
59
S
21
G
9
Posts: 641
Reputation: 9,787

Post » Thu Sep 04, 2014 8:08 pm

Yes but it still shouldn't hang when preloading audio is enabled. Can you confirm r179 fixes it with preloading enabled?
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,772

Post » Thu Sep 04, 2014 8:24 pm

r179 fixes the issue completely (Y)
B
59
S
21
G
9
Posts: 641
Reputation: 9,787


Return to Closed bugs

Who is online

Users browsing this forum: william31 and 2 guests