Audio Mute and Volume issues on mobile

Get help using Construct 2

Post » Fri Jan 24, 2014 5:09 pm

B
17
S
4
Posts: 31
Reputation: 1,600

Post » Fri Jan 24, 2014 5:10 pm

This one works!

Well this time it worked. I've never had a problem before. I went back to my older posts and they worked fine without dropbox. I even tested the previous link and it was working. Maybe I had an issue since I was editing the pages rather than posting a new one.TheBogueRat2014-01-24 17:12:18
B
17
S
4
Posts: 31
Reputation: 1,600

Post » Fri Jan 24, 2014 5:46 pm

I think my issue is slightly different and therefore have moved to a new thread. However, I thought that you guys may either have insight or benefit from the potential outcome of that thread.

Have a look...

iOS mute/unmute issues & sound vs. music folders

Thanks for trying to help me out! As always the C2 forum has been great!
B
8
S
3
G
1
Posts: 18
Reputation: 1,209

Post » Sat Jan 25, 2014 8:31 am

@TheBogueRat - the link looks alright but it seems that you didn't set public sharing to the file on dropbox. I appreciate u keep trying :)

Some good news on my project: I deployed the project to my server and I'm getting much better results. So it looks as there is a Preview on LAN issue involved as well....
The looping is not very precise but it is good enough for my needs.

For future reference, my solution is:
1. Use the Audio folder and NOT the Music folder.
2. Preload, Play and Pause all your audio loops.
3. Play non-looped audio and re-trigger it at end of file.
4. For activating a specified sound use Seek (to sync the new loops to the loops that are already playing) and Resume.
5. For deactivating a sound use Pause.
6. Add a re-sync event: this is a repeating event that sends an identical Seek command to all sounds. This will fix sync problems that may occur due to performance limitations.
B
12
S
3
Posts: 104
Reputation: 1,655

Post » Sat Jan 25, 2014 4:48 pm

example

I think I'll just use my website as a source then.TheBogueRat2014-01-25 16:53:27
B
17
S
4
Posts: 31
Reputation: 1,600

Post » Mon Jan 27, 2014 10:42 am

works at last :) thnx.
B
12
S
3
Posts: 104
Reputation: 1,655

Previous

Return to How do I....?

Who is online

Users browsing this forum: R0J0hound and 64 guests