Audio On Ended doesn't fire with Time Scale 0

Bugs will be moved here once resolved.

Post » Sun Oct 05, 2014 9:46 pm

Problem Description
If Time Scale is 1 then
- playing a audio file with a Tag will result in the On Ended "tag" event occurring as you would expect.

If Time Scale is 0 then the On Ended event does not occur.


Attach a Capx
____ Upload a Capx to this post ____

Description of Capx
The moving sprite will stop when you click the timescale = 0 text. It will move again when you click Time Scale On text.

Clicking on either will result in audio file being played with a "MyTag"

Steps to Reproduce Bug
  • Step 1 - press time scale on (hear pinball noise and then cymball - ymabll is played on the On Ended event.
  • Step 2 - press time scale off (hear pinball sound again - but no cymball - On Ended never fires)
  • Step 3 etc.

Observed Result
as above

Expected Result
as abpove

Affected Browsers
  • Chrome: (YES/)
  • FireFox: (YES/)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
win 7

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____ 178 64 bit
You do not have the required permissions to view the files attached to this post.
B
37
S
9
G
5
Posts: 437
Reputation: 6,094

Post » Mon Oct 06, 2014 3:50 pm

Thanks, good catch. Should be fixed in the next build.
Scirra Founder
B
397
S
236
G
88
Posts: 24,408
Reputation: 194,496


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests