Audio Position on Object in Chrome

Bugs will be moved here once resolved.

Post » Mon Jul 01, 2013 4:07 pm

I saw the bug report based on location, but this one is based on distance. Not 100% sure it's a bug, but I'm not sure how it can be useful.

Link to .capx file (required!):
https://dl.dropboxusercontent.com/u/50465867/Errors/SoundBug.capx

Steps to reproduce:
1. Just play the game.
2. Click on the screen, play attention to the audio volume.
3. Use the right arrow key to move over to the right.
4. Click on the screen again, notice how the volume gets lower.
5. Move back over to the left when done.
6. Click on the screen, notice how the volume gets higher again.

Observed result:
Positional volume gets lower the further away from position 0,0 you are.

Expected result:
Positional volume should be based on the distance from the centre of the screen to the object, not 0,0.

Browsers affected:
Chrome: yes
Firefox: no
Internet Explorer: no

Operating system & service pack:
Windows 7 64bit, SP1

Construct 2 version:
r136
    SoundBug
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
78
S
11
G
6
Posts: 958
Reputation: 10,081

Post » Mon Jul 01, 2013 6:07 pm

I don't have the beta version installed, but from what you described with the 0,0 position, did you set the audio listener object yet?
I got a game that you multiply, breath fire with two heads and brawl foes to oblivion with your clones: http://www.newgrounds.com/portal/view/660664 (use Chrome on Windows for best performance)

My sites:
http://twinblazar.deviantart.com
http://twinblazar.newgrounds.com
https://twitter.com/twinblazar
http://www.pixiv.net/member.php?id=15072448
B
30
S
11
G
11
Posts: 411
Reputation: 8,459

Post » Mon Jul 01, 2013 8:09 pm

I thought the listener was only for the Z plane. The bug only happens in Chrome, so I don't think it's something I'm missing.

I may be wrong...
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
78
S
11
G
6
Posts: 958
Reputation: 10,081

Post » Tue Jul 02, 2013 8:58 am

I think this is what keroberos meant :

https://dl.dropboxusercontent.com/u/89517854/Sound_fixed.capx

rock on,
Michael
B
15
S
6
G
3
Posts: 23
Reputation: 2,733

Post » Tue Jul 02, 2013 12:19 pm

Ahh, thanks @Grave

Sorry I misunderstood @keroberos

So it was Internet Explorer and Firefox that weren't working, rather than Chrome. Interesting.

Thanks a lot!
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
78
S
11
G
6
Posts: 958
Reputation: 10,081

Post » Tue Jul 02, 2013 12:38 pm

Closing as not a bug: you haven't set a listener object.
Scirra Founder
B
378
S
219
G
84
Posts: 23,859
Reputation: 187,891


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests