Audio still not working in R119 on iOS?

Discussion and feedback on Construct 2

Post » Sat Feb 16, 2013 5:39 pm

Guys I need your help please, my games are not outputing sound on iPads/iPhones/iPod Touch in Safari and those are my main platforms.

I tested it with an iPad 4 and an iPod Touchh 4, both with iOS 6.0 in Safari.

I have the 2 file formats (ogg and m4a on the server).

What Am I doing wrong? Do you guys succeed with audio on iOS?

Thanks in advance.
I made 2 games so far: www.ID-Games.net
B
9
S
2
Posts: 47
Reputation: 1,315

Post » Sat Feb 16, 2013 5:43 pm

Are you sure your server sends the .m4a files with the correct MIME type? That's one of the most common mistakes.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Sat Feb 16, 2013 7:13 pm

Thanks a lot for the reply Ashley!

I'll verify that with my webhoster, sadly the server is a IIS wich means I can't add the mime type myself if I read right on the net.

One last quick question. :) It can be this even if the sound work like 1 time on 10 or 20 in my game? (without updates to the games between the tries) Thanks!
I made 2 games so far: www.ID-Games.net
B
9
S
2
Posts: 47
Reputation: 1,315

Post » Sat Feb 16, 2013 8:40 pm

I specified my MIME type settings for m4a and it worked...one time...how can that be possible Ashley...?   

I searched on the Forum and found an answer from you saying to change directory...I tried that...it worked...anotehr time...and after that 1 game on 5 approximately. I don't get how it's possible...any idea?

I didn't update the game in-betwwen my tries, just hit "Refresh" in Safari on my iPad 4.
I made 2 games so far: www.ID-Games.net
B
9
S
2
Posts: 47
Reputation: 1,315

Post » Sun Feb 17, 2013 8:42 pm

Hey Ashley, I found a way to make my sounds work every time and not inconsistently on iOS.

Hoping it will help you maybe for a future update? I removed my sounds files from the offline.appcache file and it works now in every game if I hit refresh or not.   

So it seems iOS don't handle very well the caching of m4a files for now...?

Ashley/Guys, Should I post that into the bugs section?

Thanks for the awesome program!
I made 2 games so far: www.ID-Games.net
B
9
S
2
Posts: 47
Reputation: 1,315

Post » Mon Feb 18, 2013 11:46 am

@DavidA13 - it must be a Safari bug because it works fine in Chrome. Also, your game won't work offline now.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580


Return to Construct 2 General

Who is online

Users browsing this forum: Artpunk and 11 guests