Audio Trouble with Windows Phone Plugin (help)

Get help using Construct 2

Post » Thu Nov 28, 2013 2:51 am

I'm using the Windows Phone 8 plugin and having some issues with the audio locking up a game when it triggers audio. When testing in browser the game plays fine (no sound since i'm using the WP8 audio calls)

I even did a port of the completed demo game over and it locks up as well.. so i'm wondering if one of the recent C2 updates might be causing issues with it.

I'm doing a new project from scratch to test it as simply as possible. I'll post a project example soon once i have something i know is good.

I have emailed TheHen who made the plugin, but I was curious if anyone else has encountered this kind of problem.

I just wonder if an maybe with all the updates with C2 that maybe something has broken?


Thanks,
Caleb
B
59
S
9
G
1
Posts: 970
Reputation: 6,611

Post » Thu Nov 28, 2013 11:17 am

If you don't receive a response, post in here
B
47
S
18
G
84
Posts: 2,271
Reputation: 49,796

Post » Thu Nov 28, 2013 1:40 pm

Hey @part12studios, I replied to you yesterday. Did you follow the tutorial as I suggested?
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,945

Post » Fri Nov 29, 2013 6:05 am

Hi there,

I followed the tutorial in that i did add the wavs to the project.. i was under a very strict deadline to get things working so i really didn't care if the audio worked (thus using functions to determine if it was on WP8 or standard web). My goal (while i understand a shortsighted one) was to just get audio working on WP8 device.. no concern about audio working on web or other places.

I guess I was under this assumption.. i should be able to use the WP8 audio trigger instead of the standard one so long as I use wav files instead of the m4a files. Is this correct? if so this is what i'm doing. to be clear i don't have to name the files "mysound.wav" i jsut name them "mysound" pointing to the wav in that audio folder.


So yes I did cut a few corners but I feel like I hit all the important points which i'm outlining below.

I have all wav files for the audio. the big kicker for me is that the actual completed project locked up for me as well. So I feel like either I did something wrong (certainly a good chance heh) for both projects or the issue might something broke with one of the recent updates?

to retrace my steps to get the completed project over i:

1. opened the WindowsPhoneTutorialFinished project in C2..

2. exported as a phone 8 project

3. copied over the c2runtime.js to the WindowsPhonePluginForConstruct2 project folder + the media / images

4. added the wavs and png files to the project

5. compiled / pushed to my lumia 920..

6. when i run it it loads but locks up as soon as the audio trigger fires off in the game scene.


This is exactly what happens to me when i use the audio behavior in my game.. when audio is triggered the app lock up on WP8 hardware.


Thanks!
Caleb
a
B
59
S
9
G
1
Posts: 970
Reputation: 6,611

Post » Sat Nov 30, 2013 5:17 am

Did you make sure you removed any of the standard audio object calls? If there is even one the game will lock up when it is hit.
B
49
S
12
G
10
Posts: 1,833
Reputation: 14,603

Post » Sun Dec 01, 2013 5:12 am

@bluephase yes all of them are disabled.. they are still in there, but i've tested in browser that there is no sound when i play it in a browser, which is consistent with the game.

maybe disabling them is not enough?
B
59
S
9
G
1
Posts: 970
Reputation: 6,611

Post » Sun Dec 01, 2013 9:03 am

I get no sound in my first 2 layouts which is weird, but in all the others it works. Since I export separate projects for each platform, I just removed all sound that was not for windows phone and also removed all the non .wav files as well. I had to triple check all of my event sheets as I had a couple that were not used very often that had some audio object calls hidden deep in some functions.
B
49
S
12
G
10
Posts: 1,833
Reputation: 14,603

Post » Sun Dec 01, 2013 11:58 pm

TheHen is going to get back to me about it this coming week. he is on vacation so I'll let you know what I hear about it.

I would approach a project the same way, making a unique one for each platform. i was participating in a Nokia DVLUP challenge so that's why this project is WP8 only.
B
59
S
9
G
1
Posts: 970
Reputation: 6,611

Post » Mon Dec 02, 2013 5:37 am

Yeah, I Have a WP8 version of my game that I am in the process of trying to publish but I have to figure out how to clean up all the extra stuff in the project that comes with the WP8 plugin that thehen posted. :) Do you have a link to the Nokia competition?
B
49
S
12
G
10
Posts: 1,833
Reputation: 14,603

Post » Mon Dec 02, 2013 3:40 pm

They had a recent Nokia DVLUP day event here in Boston and the challenge was linked to that. It wasn't public, but if you're publishing to WP8 check out http://www.dvlup.com/SignIn as they have various challenges and rewards. It's a pretty cool program really for the WP8 market.

Oh hey yea about that.. you don't have to really change much! I learned this from my own recent experience and having worked with some guys over at Microsoft as well who helped out at the event.

- you don't need to change all the file names and such.. my file that I uploaded is called WindowsPhonePluginForConstruct2_Release_AnyCPU.xap as long as you change the "Display Name" under WMAppManifest.xml to your game name, so it shows up named right on the phone.

also if you notice the blue loading screen with the graphic.. if you want to change the color, update the line in MainPage.xaml below to reflect black (#000000) or whatever color you want.

Like the tutorial says all you have to do copy over media and assets, etc..

Also be sure your icons have no transparency to them. they should be solid pngs. A buddy of mine had that happen to him when he submitted his.

Lastly, be sure to check out my recent blog post here about the overall process. http://part12studios.com/2013/12/construct-2-windows-phone-publishing-tips/ i'm sure it will get some revision as i learn more and have the app 100% on the app store which right now I'm waiting on..

Thanks,
Caleb
B
59
S
9
G
1
Posts: 970
Reputation: 6,611

Next

Return to How do I....?

Who is online

Users browsing this forum: matriax and 9 guests