Audio truncated when exporting to iPhone

Bugs will be moved here once resolved.

Post » Sun Feb 24, 2013 6:09 am

Link to .capx file (required!):
https://dl.dropbox.com/u/16469485/constructbug.capx

Steps to reproduce:
1. Preview game - it's a simple test app where touching Crono causes an animation and a sound to play.
2. Export game to appmobi and run on iPhone (had similar results on CocoonJS but appmobi's sound was moderately better)
3.

Observed result:
The sound is different between a PC and the iphone. On iphone, the sound is truncated - interestingly if you touch the character quickly some of the audio plays correctly.

Expected result:
The sound should be consistent between a PC and mobile

Browsers affected:
Chrome: no
Firefox: no
Internet Explorer: no

Operating system & service pack: Windows 7

Construct 2 version: Release 120.2
    ChrisAlgoo2013-02-24 06:15:59
B
17
S
4
G
4
Posts: 143
Reputation: 4,004

Post » Mon Feb 25, 2013 5:04 pm

I don't think this is a Construct 2 bug. I can reproduce the problem using preview-over-Wifi on an iPad 2, but the m4a definitely has the correct audio content. I think it's just the fact AAC is unsuitable for very short audio clips, or the iOS AAC decoder has truncation issues. You might want to take it up with Apple.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Post » Tue Feb 26, 2013 3:25 am

Are there any workarounds, or other ways that I can play short sounds at high fidelity in my mobile games?
B
17
S
4
G
4
Posts: 143
Reputation: 4,004

Post » Tue Feb 26, 2013 12:27 pm

You could try padding your audio clips with silence, but that might cause other issues with the delay before the sound plays.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests