"Auto mirror" in platform behavior doesn't work.

For questions about using Classic.

Post » Sun Nov 16, 2008 6:07 am

http://machriderx.googlepages.com/automirror.cap

I have "Auto Mirror" toggled on yet it does nothing when I test it ingame. Am I doing something wrong here or is this a glitch?
B
2
S
2
G
4
Posts: 153
Reputation: 1,756

Post » Sun Nov 16, 2008 6:38 am

I'm not sure, but I'm pretty sure you have to manually set the angle of the object. For example, if the X speed is less than 0, the angle equals 180. If X speed is greater than 0, the angle equals 0. That should work. Hope it helps. :)
Moderator
B
99
S
38
G
19
Posts: 1,584
Reputation: 17,942

Post » Sun Nov 16, 2008 8:04 pm

Yeah, that's another way of doing it.

But the "automirror" option under the platform behavior properties is supposed to do that for you, without any events. And it doesn't seem to be working.

I guess I'll just file a bug report then.
B
2
S
2
G
4
Posts: 153
Reputation: 1,756

Post » Sun Nov 16, 2008 8:40 pm

I think more of what it is is that the platform movement doesn't change the angle depending on what direction you're going. I don't think it's really a bug in the auto mirror option.
Moderator
B
99
S
38
G
19
Posts: 1,584
Reputation: 17,942

Post » Mon Nov 17, 2008 5:38 pm

You can use two behaviors for that :
1= 8Direction ( directions left/right)
2= Platform
and auto mirror = true

http://sites.google.com/site/doo89const ... soluce.cap
B
64
S
25
G
8
Posts: 11
Reputation: 7,089


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests