Background layer completely behind layout?!

Just started using Construct 2? Post your questions here

Post » Fri Sep 19, 2014 1:11 pm

Can somebody please explain what is going on here? I created a new layout and added a second layer. all the settings for both the layout and the layer seem to be exactly the same as the ones created by or cloned from the construct platformer template. What could I possibly be doing wrong? :(

Image
Image
Image
Image




Other observations:
Changing the order of the two layers DOES change which one is above the layout and which one is not.
Making a third layer will cause all layers except the top one to be behind the layout like this.
Changing Z order within the layer does nothing. Switching objects to the other layer WILL change whether they are behind the layout or not. The problem is clearly the layer and not the object(s).
B
15
S
2
Posts: 103
Reputation: 1,178

Post » Fri Sep 19, 2014 1:33 pm

You've got "Game" layer property 'Transparent' set to 'No'. Set it to 'Yes'.
ImageImageImage
B
71
S
22
G
241
Posts: 3,734
Reputation: 134,494

Post » Fri Sep 19, 2014 1:39 pm

blackhornet wrote:You've got "Game" layer property 'Transparent' set to 'No'. Set it to 'Yes'.


Omg, total thank you man. I would have sworn I checked every little thing, including the transparency. But I was only focused on the background layer, not the game layer, which I paid no mind at all. In fact, I had even considered not including it in the screenshots here, because I subconsciously thought it was irrelevant. Thank god I still did include it. <3
B
15
S
2
Posts: 103
Reputation: 1,178


Return to Beginner's Questions

Who is online

Users browsing this forum: brunopalermo and 4 guests