Bad Scroll in Editor on Large Layouts

Discussion and feedback on Construct 2

Post » Mon Nov 17, 2014 9:46 pm

When you set the Layout increasing the 43000 px width, (or height), the scroll bar won't work properly while you move along the width. Near the border, the scroll bar jumps to the end. It's impossible to view the entire layout moving the bar. Only the continuous click on the arrows (left/right) works fine.

As usually, excuse me for my english please.

Greetings.
B
25
S
3
G
1
Posts: 53
Reputation: 1,417

Post » Tue Nov 18, 2014 5:23 pm

Sorry. Maybe I forgot to make the Question here :D
Is it a known bug? SOme of you have had the same problem?
B
25
S
3
G
1
Posts: 53
Reputation: 1,417

Post » Thu Nov 20, 2014 6:53 am

I have similar problem. And it is serious problem, because 43000px width is not really big, especially when you build level with high resolution graphics. So slider is not working - you can only click arrows.

@Ashley
B
18
S
6
G
1
Posts: 783
Reputation: 4,187

Post » Thu Nov 20, 2014 8:46 am

I just noticed this yesterday when testing a large layout, though I didn't take note of the exact point at which the slider bar glitched up. It doesn't seem to cause any functional difference to the layout itself though.
Don't lose your work. Backup your game with Dropbox.
B
44
S
10
G
10
Posts: 1,106
Reputation: 9,187

Post » Thu Nov 20, 2014 10:29 am

So, Ashley can you help us with that? :|
B
25
S
3
G
1
Posts: 53
Reputation: 1,417

Post » Thu Nov 20, 2014 2:14 pm

File a bug report following all the guidelines or it won't be investigated.
Scirra Founder
B
387
S
230
G
87
Posts: 24,245
Reputation: 192,210

Post » Thu Nov 20, 2014 5:22 pm

@Ashley
@thegodo

Related bug report I think.
viewtopic.php?f=151&t=100617
Game design is all about decomposing the core of your game so it becomes simple instructions.
B
52
S
22
G
18
Posts: 2,122
Reputation: 17,093

Post » Sat Dec 06, 2014 9:55 am

Ashley, should I make a new bug report then? Or this one is what you was refering to? According to Aphrodite it was reported already, wasn't it?
B
25
S
3
G
1
Posts: 53
Reputation: 1,417

Post » Mon Dec 08, 2014 5:19 pm

Same problem with my 120,000 px layout.
Image
B
60
S
10
G
10
Posts: 1,013
Reputation: 9,155

Post » Tue Dec 09, 2014 3:04 pm

I encountered some strange behavior in the layout view. Some objects aren't rendering properly in the editor but render fine when I run the layout. I can't figure out how to reproduce it with a minimal project file though (or rather, too busy trying to make my game) that I haven't been able to submit a good enough bug report.
B
10
S
2
G
2
Posts: 73
Reputation: 1,044


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 2 guests