[BEHAVIOR] Sonic Physics

Post your work in progress addons and get feedback

Post » Fri Apr 29, 2016 1:14 am

Thanks of the reply. There's a bug I found with this behaviour. In my project I have tilemaps setup used as the ground, set with a behaviour of Solid, if the player tries to move across any of these tilemaps, everything disappears off the screen. I tried making a new project and found out that this only happens with the SonicPhysics and not with any other behaviour. Fix would be great. Also player get's stuck on pixels on the ground while moving?
B
15
S
6
G
3
Posts: 11
Reputation: 2,707

Post » Sat Apr 30, 2016 10:41 am

@patchester:
Yep, tilemaps are still not working. It's one of the higher priorities at the moment, though. Would you be able to give me more details on that second issue?
B
75
S
27
G
12
Posts: 127
Reputation: 11,765

Post » Sun May 01, 2016 1:54 am

While playing in game, the Player gets stuck on some pixels on slopes and such and Is only able to jump.
B
15
S
6
G
3
Posts: 11
Reputation: 2,707

Post » Mon May 02, 2016 2:19 am

@patchester
What kind of slopes cause this issue? Does it happen anywhere in particular in the example?
B
75
S
27
G
12
Posts: 127
Reputation: 11,765

Post » Sat May 14, 2016 2:04 am

Most slopes, mainly on the Concave you provided.
B
15
S
6
G
3
Posts: 11
Reputation: 2,707

Post » Sun Jul 17, 2016 8:19 pm

B
68
S
17
G
2
Posts: 94
Reputation: 4,742

Post » Sun Jul 31, 2016 8:12 pm

I swear it was reported in here before, but attempting to change the soft max speed via events seems to cause an error.
B
8
S
1
Posts: 58
Reputation: 570

Post » Mon Aug 01, 2016 7:03 am

@Poxnixles
Looks like it has been reported before, way back in March, actually, and I've just been slow about getting to a bugfix release. Has been fixed, thank you.

@MatheusCastellar
Thanks, though it's worth noting that I've been using the SPG since the beginning of this. Awesome resource, essentially fundamental for this kind of thing. Now that I think of it, though, I ought to have that linked in the main post.

And so now that I'm sitting down and responding, I can see that it's been more than a year since I first released this, and getting close to a year since any kind of actual update. I apologise, I've been more caught up than I realised with work and uni. I genuinely appreciate the patience, especially as I seem to be still getting bug reports every now and then despite my lack of progress here.
While I still haven't had time to fix some of the more fundamental issues that have been bogging things down, I've made a long-overdue bugfix build, and updated the opening post.

Changelog:

-Set Soft Max Speed now works
-Vector Y is no longer capped to Min Jump Strength if jump button isn't held (will allow springs and bumpers to work)
-Rolling Jump Control Lock now functions if enabled
-Removed Is Double Jump Enabled condition

Feedback is still appreciated. If there's anything clearly broken I'll try to get to it ASAP, though I unfortunately still can't give an ETA on much-needed core improvements (such as tilemaps).
B
75
S
27
G
12
Posts: 127
Reputation: 11,765

Post » Mon Aug 01, 2016 7:40 pm

nice! a bugfix :D

when you get around tackling the tilemap issues, I noticed that solid tiled backgrounds freak out objects with the sonic physics behavior, namely they warp the object into a NaN XY position and there is no coming back after that, because if XY coords are not a number, gravity and other forces fail to kick in.
Image
Image
Image
B
15
S
2
Posts: 48
Reputation: 1,597

Post » Tue Aug 02, 2016 9:29 pm

Seems to have the info.xml is missing from root issue.
B
8
S
1
Posts: 58
Reputation: 570

PreviousNext

Return to Work in Progress Addons

Who is online

Users browsing this forum: No registered users and 1 guest