Black background instead of image for game

Bugs will be moved here once resolved.

Post » Tue Mar 03, 2015 3:19 pm

Problem Description
Hi when I export and upload my html5 project the background image gets removed and it becomes black. Everything else is correct. However this is random as on my Mac Firefox I have a black backgrounf but Windows doesn't and someone else got it in Chrome but I don't. I've tried everything I can think of but can't get the background to always be there. Any help on this would be appricated as I just can't seem to find why it is doing this.

Attach a Capx
game.capx


Steps to Reproduce Bug
Random could happen in any browser.

Observed Result
Backgroudn image is removed on random browsers and for mobile.


Affected Browsers
  • Chrome: (YES for someone else)
  • FireFox: (YES only on my Mac)
  • Internet Explorer: (NO)
  • Opera: (NO)

Operating System and Service Pack
OSX 10.09 - 10.10, Windows 7, iOS 8 and Android 4.4

Construct 2 Version ID
Release 195
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 1
Reputation: 177

Post » Mon Mar 09, 2015 12:04 pm

If it works in C2's preview mode but not after you export, either you are running it wrong (e.g. trying to run from disk, which won't work), you uploaded it to the server wrong (e.g. missing some files), or the server configuration is incorrect (e.g. missing MIME types). It's also possible it's a glitch caused by buggy graphics drivers. None of these are bugs in C2. Include a link to your published game for more information.
Scirra Founder
B
373
S
218
G
84
Posts: 23,525
Reputation: 186,342


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest