Black screen after exporting project

Bugs will be moved here once resolved.

Post » Mon May 12, 2014 10:12 pm

Problem Description
____ Blank Screen when exporting project.
I've attempted to export the project to Kongregate and the preview only shows a black screen.
Same issue can be seen when opening the index.html file from in a local or cloud environment
NOTE: For a fraction of time the C2 loading screen is shown____

Attach a Capx
____ See attached capx project____

Description of Capx
____ Capx project is just a test project to show the problem (a single sprite visible on layout load) ____

Steps to Reproduce Bug
  • Step 1
    Export project as type "Kongregate"
  • Step 2
    Upload the entire folder to an online address
  • Step 3
    Point the iframe to the hosting folder into the Kongregate shell file
  • Step 4
    Go trough the Upload process until "Preview" step via Kongregate (http://www.kongregate.com/games/new)


    Observed Result
    ____ Notice that the preview is not shown at all, a black screen is shown instead ____

    Expected Result
    ____ uploaded content should be displayed in Preview mode ____

    Affected Browsers
    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)

Operating System and Service Pack
____ Windows 8.1 ____

Construct 2 Version ID
____ Release 168 (x64)____
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 3
Reputation: 181

Post » Wed May 14, 2014 1:31 pm

Hi there, is there any person in charge of support or having an unanswered bug forever is a feasible scenario?
Thanks!
Pedro.-
B
3
Posts: 3
Reputation: 181

Post » Sat May 17, 2014 6:31 pm

You should check your browsers console log for any errors in the script. You could try turning off webgl. Also maybe uncheck minify script when you export.

I have no experience exporting to Kongregate these are just guesses.
B
6
S
2
Posts: 151
Reputation: 1,366

Post » Sat May 17, 2014 6:39 pm

The majority of people helping out and answering questions are users just like yourself, so you're tone isn't particularly appreciated.

Ashley has often said it may take him up to a few weeks to properly investigate a problem.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
132
S
29
G
81
Posts: 5,328
Reputation: 56,655

Post » Sun May 18, 2014 1:32 am

Well, thanks EyezWidee and zenox98 for you replies.

I'll try turning off webgl as you suggested EyesWidee.

Zeno (And of course Ashley), I didn't meant to be rude (Actually I wasn't), just wanted to know if the Scirra team have a support team paying attention to issues submitted by users or it is just a community supported framework.
Let me tell you, I think Construct is a pretty good tool, but as every paid tool it should have a paid support team behind.

Cheers,
Pedro.-
B
3
Posts: 3
Reputation: 181

Post » Tue May 20, 2014 12:42 pm

Since the reproduction steps involve uploading and publishing via Kongregate, and the problem is not reported to occur anywhere else, this just sounds like a mistake during the publishing process and not a Construct 2 bug. Users commonly forget to upload some files, which breaks the game, and sometimes try to report this as a bug. Look in the browser error console for more information.
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,464

Post » Wed Oct 12, 2016 2:58 pm

Hello, any solution to this problem?
Thank you
B
5
Posts: 11
Reputation: 258


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests