Black screen in exported via cordova/xdk projects

Bugs will be moved here once resolved.

Post » Wed Apr 27, 2016 10:43 am

Ashley wrote:I can't reproduce this at all. I have now built iOS apps with the Intel XDK in the following combinations:
Reported .capx - new XDK project format - WKWebView - unminified
Reported .capx - new XDK project format - WKWebView - minified
sbperftest - new XDK project format - WKWebView - unminified
sbperftest - new XDK project format - old webview - unminified
sbperftest - old XDK project format - old webview - unminified
All five tests were exported with r227 and ran fine built by the Intel XDK running on an iPad Air 2 (iOS 9.3.1).

I'm guessing it might be one of these issues:
- are you testing on an older version of iOS? Maybe iOS 8?
- are you re-exporting over the same XDK project? I heard there are known bugs with that - I used a fresh project each time
- are you sure your build settings are all correct? I was testing with a newly configured certificate (it said something about being able to import an older certificate, but I couldn't build with that)


@Ashley iOS was 8 and 9, same trouble on both. About re-exporting i always use fresh builds. Build settings is correct. As i see problem on costruct 2 side somewere in export starting from b224. Guys here have same problem as i understand with same construct builds.
Creator of MiniDayZ
B
22
S
2
G
2
Posts: 75
Reputation: 1,858

Post » Wed Apr 27, 2016 5:04 pm

r224 didn't have any major changes other than adding WKWebView support, and if you disable it, it should have exported an identical result to r223. So I am suspicious somehow WKWebView support is actually being enabled when you get a black screen. Then if you are missing certain Cordova plugins, it would fail to start up.
Scirra Founder
B
395
S
231
G
88
Posts: 24,367
Reputation: 193,694

Post » Thu Apr 28, 2016 10:33 am

Hello Ashley I have the same problem when exporting to the new WKWebView format .
A black screen Appears I am using IOS 9.0.2 Iphone 5S - Stable Release (r227)
B
13
S
2
G
1
Posts: 40
Reputation: 2,033

Post » Thu Apr 28, 2016 3:34 pm

Hello I recognized something weird in my project when I close the app and then open it on IOS only the first 4 layers are rendered and the rest of the layers they do not appear on the screen after the black screen issue .
B
13
S
2
G
1
Posts: 40
Reputation: 2,033

Post » Fri Apr 29, 2016 6:02 am

@Ashley In my project I found the problem the scml plugin is not working with the wkwebview would you like me to report it as a bug .
Create a new project and import any spriter file then export and build with wkwebview engine on intel xdk it wont run some times a black screen appears if it was on a separate layer .
B
13
S
2
G
1
Posts: 40
Reputation: 2,033

Post » Fri Apr 29, 2016 9:34 am

@mediadi - that's a third-party plugin, so you'll need to report it to the plugin developer.
Scirra Founder
B
395
S
231
G
88
Posts: 24,367
Reputation: 193,694

Post » Sat Jun 11, 2016 10:46 am

I am also getting black screen issue
I am exporting to cordova compile in intel xdk android crosswalk
why black screen is coming
how to fix this issue ??
Image
B
64
S
39
G
45
Posts: 647
Reputation: 32,206

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests