Blurred pixels

Discussion and feedback on Construct 2

Post » Mon Nov 17, 2014 2:54 pm

Hi there

I have noticed that there have been a few posts about the issue with blurred pixels. Like myself, these issues seem to be rectified by accident rather than design. Right now I have an issue where my game displays pixel perfect in internet explorer but looks blurred in firefox. None of my images are displaying between pixels & my pixel rounding is turned on. Firefox will display the game perfectly at 100%, but below that it has trouble.

I am on the latest version of firefox and I have followed suggestions that have been posted previously. Has anyone else had a similar problem, is there a solution? Like I say, the issue seems to randomly solve itself, which is frustrating at 4 in the morning when I'm staring at code and crying inside.

Thanks for reading.

Paul
B
3
Posts: 2
Reputation: 179

Post » Mon Nov 17, 2014 3:58 pm

Both Firefox and Chrome have default bilinear filter settings that kick in when you zoom in on images. There are scripts around to circumvent those settings such as this here:

http://wayofthepixel.net/index.php?topic=16963.0

But those tweak the browser on your end and isn't a big help for deploying C2 games I guess. Have you tried setting sampling to point in project settings yet? You probably did, just checking :P
B
39
S
16
G
6
Posts: 542
Reputation: 7,617

Post » Tue Nov 18, 2014 6:06 pm

Thanks for the reply! I'll check the script out :)

Already set to point in the project settings so I'll give your idea a go. Thanks again ErekT
B
3
Posts: 2
Reputation: 179


Return to Construct 2 General

Who is online

Users browsing this forum: Solomon and 3 guests